incubator-esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Hirsch <hirsch.d...@gmail.com>
Subject Re: Build failing because of OpenDMK missing?
Date Wed, 18 Nov 2009 18:45:46 GMT
@Andy:

Sounds great.

I can't wait to combine your JMX code with Markus' performance tests.
Then we will definitely get some interesting results.

Just ping me when you are ready and I'll integrate everything.

D.

On Wed, Nov 18, 2009 at 7:42 PM, Andy the destroyer
<andythedestroyer@gmail.com> wrote:
> We actually don't need openDMK anymore. It was used as an HTTP agent for
> accessing the Stats mBean. However, the Stax environment won't allow the
> agent to bind to any ports so it won't work in Stax which is where most of
> the testing is done.
>
> I have written a JMX REST api to replace it. I haven't uploaded it to JIRA
> yet because I still need to find the time to finish the piece that allows
> you to invoke operations on MBeans, but the reading of attributes works.
>
> I think it is a good idea to leave agents out of the codebase and leave it
> up to whoever is deploying esme to write their own instrumentation agents
> and launch them through the java -javaagent argument.
>
> -Andy
>
> On Wed, Nov 18, 2009 at 9:41 AM, Ethan Jewett <esjewett@gmail.com> wrote:
>
>> I could swear that this exact same thing happened to me, where it was
>> only the one thing that failed to download. If you send the actual
>> Maven error, I'll recognize it. In any case, maybe it was actually the
>> server, not the firewall...
>>
>> Ethan
>>
>> On Wed, Nov 18, 2009 at 12:01 PM, Markus Kohler <markus.kohler@gmail.com>
>> wrote:
>> > No difference.
>> > I suspect the file is just not on the server anymore. I guess it should
>> be
>> > on maven.tigase.org.
>> >
>> > On Wed, Nov 18, 2009 at 5:52 PM, Markus Kohler <markus.kohler@gmail.com
>> >wrote:
>> >
>> >> Yes, it does not find the jar file.
>> >> Yes I'm behind an http proxy. But downloading everything else worked.
>> >> I will try without the proxy server.
>> >>
>> >> Regards,
>> >> Markus
>> >>
>> >>
>> >> On Wed, Nov 18, 2009 at 5:47 PM, Ethan Jewett <esjewett@gmail.com>
>> wrote:
>> >>
>> >>> Hi Markus,
>> >>>
>> >>> The build works fine for me (mvn clean test). I think I had an issue
>> >>> with OpenDMK once when I was behind a firewall. Is it possible that
>> >>> Maven is just failing to download the artifact?
>> >>>
>> >>> Ethan
>> >>>
>> >>> On Wed, Nov 18, 2009 at 11:25 AM, Markus Kohler <
>> markus.kohler@gmail.com>
>> >>> wrote:
>> >>> > Hudson build run through, but it doesn't seem to do anything useful.
>> >>> > - downloaded jetty util jar files several times.
>> >>> > - 0 tests executed because of exception, but no failure shown in
the
>> >>> > overview
>> >>> >
>> >>> > Can you force a clean build, maybe?
>> >>> >
>> >>> >
>> >>> >
>> >>> > Regards,
>> >>> > Markus
>> >>> >
>> >>> >
>> >>> >
>> >>> > On Wed, Nov 18, 2009 at 1:36 PM, Richard Hirsch <
>> hirsch.dick@gmail.com
>> >>> >wrote:
>> >>> >
>> >>> >> trying a build on hudson to see if the problem occurs there
as well
>> >>> >>
>> >>> >> On Wed, Nov 18, 2009 at 1:05 PM, Markus Kohler <
>> >>> markus.kohler@gmail.com>
>> >>> >> wrote:
>> >>> >> > Hi all,
>> >>> >> > Anyone has the same problem?
>> >>> >> >
>> >>> >> > Regards,
>> >>> >> > Markus
>> >>> >> >
>> >>> >>
>> >>> >
>> >>>
>> >>
>> >>
>> >
>>
>

Mime
View raw message