incubator-esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Kohler <markus.koh...@gmail.com>
Subject Re: Users on http://esmecloudperf.esme.staxapps.net/ created
Date Tue, 17 Nov 2009 12:10:43 GMT
Hi all,
I just let all users logon (and not logout). We are at 500 threads already.
Regards,
markus

On Tue, Nov 17, 2009 at 12:06 PM, Mrinal Wadhwa <mrinal.wadhwa@gmail.com>wrote:

> Hey Markus,
>
> Very cool ! Thank you for setting it up.
>
> Cheers,
> Mrinal
>
>
>
> On Tue, Nov 17, 2009 at 3:10 PM, Markus Kohler <markus.kohler@gmail.com
> >wrote:
>
> > Oh and I forgot to mention.
> > I would like to checkin the test, but I still have to clarify whether my
> > company allows me to do so.
> >
> > Regards,
> > Markus
> >
> > On Tue, Nov 17, 2009 at 10:28 AM, Markus Kohler <markus.kohler@gmail.com
> > >wrote:
> >
> > > Hi all,
> > > The test is a Selenium RC test using the Java API to remotely control a
> > > real Firefox browser.
> > > Therefore it's currently single threaded. I hope that the same test
> will
> > > also run using htmlunit not using a real browser but a Java emulated
> one.
> > > With htmlunit it should also be possible to run it parallel, keep your
> > > fingers crossed. For the parallel test I would like to concentrate on
> > > posting messages first. Posting messages using Firefox already works.
> > > It would be really easily to create a test that covers the most
> important
> > > functionality.
> > >
> > > Sorry no screenshots yet.
> > >
> > > I've stopped the response time within the script, see attachment (times
> > in
> > > milliseconds). The times are for all steps including logout.
> > > Make a graph out of it and you will see it looks a bit strange. This
> > might
> > > be caused by me opening another browser on the esme performance server.
> > >
> > >
> > > Regards,
> > > Markus
> > >
> > > On Tue, Nov 17, 2009 at 10:02 AM, Richard Hirsch <
> hirsch.dick@gmail.com
> > >wrote:
> > >
> > >> Awesome.
> > >>
> > >> Could you describe the test in more detail? Was the creation of users
> > >> sequential or did you have parallel threads working?
> > >>
> > >> Do you have access to stax console? Did you take a few screen shots?
> > >>
> > >> D.
> > >>
> > >> On Tue, Nov 17, 2009 at 9:57 AM, Markus Kohler <
> markus.kohler@gmail.com
> > >
> > >> wrote:
> > >> > Hi all,
> > >> > The Selenium test script ran through and now we have more than 300
> > Users
> > >> on
> > >> > http://esmecloudperf.esme.staxapps.net/.
> > >> > I took the users from my twitter account, so you might be already
> > there
> > >> ;)
> > >> >  I say "might" because the python script I used to create a CSV file
> > >> with
> > >> > the user information doesn't seem to work 100%.
> > >> >
> > >> > It seems to me that we will already find some bugs
> > >> >
> > >> >   - the Stax console shows that at a certain point the numbers of
> > >> threads
> > >> >   went up
> > >> >   - I logged in with an existing user during the test and it seems
> its
> > >> >   timeline was not update
> > >> >   - It seems that if an avatar image is not loaded the whole page
> > >> "hangs"
> > >> >   (no updates)
> > >> >
> > >> >
> > >> > I would like encourage you to go there and test a few things
> manually.
> > >> >
> > >> > If you need the passwords for the users let me know.
> > >> >
> > >> > Greetings,
> > >> > Markus
> > >> >
> > >>
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message