incubator-esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ethan Jewett <esjew...@gmail.com>
Subject Re: Not a lot of ESME output from me today
Date Fri, 13 Nov 2009 18:57:06 GMT
Vassil,

Yeah, it's not the same error. My mistake for not checking the actual
Hudson error message. That complicates the whole matter. I'm actually
getting a complete build failure when I do "mvn test", which I think
is due only to the test failures. When I do "mvn jetty:run", it's
fine.

The other thing to keep in mind is that my local repo is out of sync
with the main one, so take what errors I have with a really huge cube
of salt for the time being. It's possible that the issue with the main
API tests will go away once I sync up.

Ethan

On Fri, Nov 13, 2009 at 1:44 PM, Vassil Dichev <vdichev@apache.org> wrote:
>> That's fair, but something is wrong, because this exception is
>> resulting in no test results at all (on either my system or on
>> Hudson). It's as if the test runner doesn't catch the exception and
>> instead of converting it to a test failure it just gives up on the
>> whole test suite.
>>
>> If the new API test is failing, I'd expect to see 21 passed tests and
>> 1 failed, but instead it's as if there were no tests at all.
>
> You're right, I assumed your error is the same as the one on hudson.
> The success message is also strange, but I think this depends on the
> maven configuration- we could set it up so that the whole build fails
> if tests fail (and we should).
>
> As for the message now on hudson, I remember seeing it in the past-
> only on the mailing list though. Do you remember what solved it?
>
> http://mail-archives.apache.org/mod_mbox/incubator-esme-dev/200906.mbox/%3C48d391a20906282007p5f0159e8x1c4500482e281aa7@mail.gmail.com%3E
>

Mime
View raw message