incubator-esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Pollak <feeder.of.the.be...@gmail.com>
Subject JSON handler doesn't respond
Date Tue, 01 Sep 2009 17:14:43 GMT
On Mon, Aug 31, 2009 at 9:51 PM, Vassil Dichev <vdichev@apache.org> wrote:

> I built Lift locally and put dumps in LiftSession's cleanupUnseenFuncs
> and updateFuncByOwner. So far I cannot reproduce the problem.
>
> >>    <snapshot>
> >>      <buildNumber>1724</buildNumber>
> >>    </snapshot>
> >>    <lastUpdated>20090828152733</lastUpdated>
> >>
> >> Do I have the correct updated jar?
> >>
> >
> > I have no idea.
>
> Since you've mentioned in the past that you're using hudson for
> building the lift jars before they're uploaded to the public maven
> repo, I was hoping that one can associate the build number or date
> with the specific commit.
>

There's an open request to associate the Git hash with the build, but
apparently Maven cannot yet do that.

In terms of build date, it's available via LiftRules.liftBuildDate


>
> > Can you specify the exact steps to reproduce the problem?  I have really,
> > really tried to make it happen and can't. :-(
>
> I'm using Firefox, on different versions of Linux. I have three users
> (e.g. a follows b, b follows c) and I open up the ESME main page in a
> separate browser for each user. I post a message for each to make sure
> it works. I leave the browsers open and after a while I check again
> whether I can send a message with all users. Usually half an hour is
> enough for 2-3 of the users to block. The problem can always be
> reproduced on the Stax instance, too, by just leaving a session open-
> Dick can confirm that it regularly happens to him, too. Maybe he can
> add some details on how he reproduces it.
>
> Let's see if the fix works this time. If not, the only difference I
> can think of is the browser- you could be using Chrome or Safari. I've
> tried reproducing with Chrome in the past once or twice and couldn't.
>
> Vassil
>



-- 
Lift, the simply functional web framework http://liftweb.net
Beginning Scala http://www.apress.com/book/view/1430219890
Follow me: http://twitter.com/dpp
Git some: http://github.com/dpp

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message