incubator-esme-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hirsch, Richard" <richard.hir...@siemens.com>
Subject AW: Maven Build is broken
Date Thu, 05 Mar 2009 07:08:51 GMT
Thanks all.
 
Build is working again and I just deployed to Stax - http://esmecloudserverapache.DickHirsch.staxapps.net
 
D. 

________________________________

Von: David Pollak [mailto:feeder.of.the.bears@gmail.com]
Gesendet: Mi 04.03.2009 19:05
An: esme-dev@incubator.apache.org
Betreff: Re: Maven Build is broken



On Wed, Mar 4, 2009 at 6:44 AM, David Pollak
<feeder.of.the.bears@gmail.com>wrote:

> Folks,
> David Bernard (Lift's Maven guru and the guy who maintains scala-tools.org)
> has some choice things to say about the way the OpenID4Java folks manage
> their pom files.  If anyone knows any of the Openid4Java guys, please
> repeatedly whack them over the head with their broken pom.
>

Okay... It's all updated!


>
> David inserted:
>
>       <dependency>
>         <groupId>com.ibm.icu</groupId>
>         <artifactId>icu4j</artifactId>
>         <version>3.4.4</version>
>       </dependency>
>     </dependencies>
>
> Into the Lift pom and it cleared up the problem.
>
> I'll update ESME to run on Lift 1.0 (yes, it's released) and hopefully it
> will make the OpenID problem go away.
>
> Thanks,
>
> David
>
> On Wed, Mar 4, 2009 at 6:32 AM, Daniel Kulp <dkulp@apache.org> wrote:
>
>>
>> Umm....    I just checked the logs at repo1.maven.org and had Brett check
>> the
>> sync logs to his mirror.    There is no indication that 3.4.1 EVER existed
>> at
>> central.   The logs indicate 4.0.1 being added, but nothing about 3.4.1.
>>
>> Are you sure you were getting that jar from central and not some other
>> repository defined in a pom someplace?   My gut feeling is that you were
>> grabbing it from someplace else and that location is no longer available
>> so
>> it's dropping down to checking central.  (remember, central is checked
>> last
>> only if it's not found elsewhere)
>>
>> Dan
>>
>>
>> On Wed March 4 2009 2:56:26 am Hirsch, Richard wrote:
>> > As Daniel pointed out last night, the maven build is currently broken.
>> >
>> > I have no idea if the problem is scala- or maven-based.
>> >
>> > http://repo1.maven.org/maven2/com/ibm/icu/icu4j/3.4.1/icu4j-3.4.1.jarcan
>> > not found, because there has been a version change from 3.4.1 to 3.4.4/
>> >
>> > Does anyone know how to solve this problem?
>> >
>> >
>> >
>> > D.
>>
>> --
>> Daniel Kulp
>> dkulp@apache.org
>> http://www.dankulp.com/blog
>>
>
>
>
> --
> Lift, the simply functional web framework http://liftweb.net <http://liftweb.net/>

> Beginning Scala http://www.apress.com/book/view/1430219890
> Follow me: http://twitter.com/dpp
> Git some: http://github.com/dpp
>



--
Lift, the simply functional web framework http://liftweb.net <http://liftweb.net/> 
Beginning Scala http://www.apress.com/book/view/1430219890
Follow me: http://twitter.com/dpp
Git some: http://github.com/dpp



Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message