incubator-empire-db-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Döbele <doeb...@esteam.de>
Subject second call for a better name
Date Thu, 28 Jan 2010 20:56:25 GMT
Hello everyone,

any idea for a better name than DataMode for our new enum anyone?

The requirements are:
- The enum contains the items ReadOnly, Nullable (or Optional), NotNull (or Required), AutoGenerated
- The name should be short (<=8) to keep data definitions small
- It should be understandable.

How about:
- Mode
- Modifier
- Mod (short for Modifier)
- (just) M
- Def
- Xtra
- X
- Claim (would semantically be right but sounds odd, doesn't it?)

Here is an example of where it is used (see DataMode...):

DEPARTMENT_ID   = addColumn("DEPARTMENT_ID",    DataType.AUTOINC,       0, DataMode.AutoGenerated,
"DEP_ID_SEQUENCE");
NAME            = addColumn("NAME",             DataType.TEXT,         80, DataMode.NotNull);
HEAD            = addColumn("HEAD",             DataType.TEXT,         80, DataMode.Nullable);
BUSINESS_UNIT   = addColumn("BUSINESS_UNIT",    DataType.TEXT,          4, DataMode.NotNull,
"ITTK");
UPDATE_TIMESTAMP= addColumn("UPDATE_TIMESTAMP", DataType.DATETIME,      0, DataMode.AutoGenerated);

Looking forward for your responses.

Regards
Rainer


> -----Ursprüngliche Nachricht-----
> Von: McKinley [mailto:mckinley1411@gmail.com]
> Gesendet: Mittwoch, 27. Januar 2010 01:45
> An: empire-db-dev@incubator.apache.org
> Betreff: Re: DataType.AUTOINC Probably Needs a Change
> 
> On Wed, Jan 27, 2010 at 12:01 AM, Rainer Döbele <doebele@esteam.de>
> wrote:
> > I am not too happy about the name of the enum (DataMode) but I have
> been thining and trying out various
> 
> DataMeta? Joking, joking.
> 
> Thanks for this patch!

Mime
View raw message