incubator-empire-db-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francis De Brabandere <franci...@gmail.com>
Subject Re: Remaining problems
Date Tue, 23 Jun 2009 13:17:26 GMT
>> 23.06.09 13:18:03 CEST: Build errors for empire-db-example-advanced;  org.apache.maven.lifecycle.LifecycleExecutionException:
Failed to construct one or more initial build plans.  Reason:
>>
>> No lifecycle phase binding can be found for goal: java,
>> specified as a part of the execution: defaultin plugin: org.codehaus.mojo:exec-maven-plugin
>>
>> This plugin was resolved successfully.
>> However, the mojo metadata it contains does not specify a default lifecycle phase
binding.
>>
>> Please provide a valid <phase/> specification for execution: default
>> in plugin: org.codehaus.mojo:exec-maven-plugin
>
> The same error is reported for the empire-db-example-basic, but not for any of the other
projects.
> I cannot run the samples either - is does not allow me to select "Debug As... / Java
Application".
>

M2eclipse should not be falling over this, maven uses a lifecycle for
each packaging type, and this exec plugin is not mapped to any of the
phases in that lifecycle. For maven this is not a problem, it seems
m2eclipse has issues with that.
But as the exec plugin is not crucial for the build (only for starting
the demo using maven) we can leave that plugin commented out for now.
I will look into a solution for that this evening.


> So I changed to the command line and ran:
> mvn clean install eclipse:eclipse sysdeo-tomcat:generate
> (@Francis: Is this correct?)

Never used the sysdeo plugin but that command looks correct

>
> Afterwards I am able to run or debug the samples.
> For some reason the empire-db-example-struts2-cxf projects reports errors which go after
I clean an rebuild the project.
> I can also run the Web-Samples using the sysdeo plugin.
>
> When I try to run the websamples using the WTP however I get the error:
> java.lang.NoClassDefFoundError: org/apache/struts2/dispatcher/FilterDispatcher
> This is because the commons and struts2 dependencies are not correctly activated in the
projects "Java EE Module Dependencies". When I check them manually, I am able to start the
sample with WTP.
> But I don't know how to get the right module dependencies checked automatically by Maven.
>
> And there is one more issue:
> When I run
> mvn clean install eclipse:eclipse sysdeo-tomcat:generate
> again I get the following message at the end:
>
> [INFO] [license:check {execution: default}]
> [INFO] Checking licenses...
> [WARNING] Unknown file extension: E:\Java\Empire-DB-MVN2\empire-db-parent\empire
> -db-examples\empire-db-example-struts2\src\main\webapp\hsqldb\sample.lck
> [WARNING] Unknown file extension: E:\Java\Empire-DB-MVN2\empire-db-parent\empire
> -db-examples\empire-db-example-struts2\src\main\webapp\hsqldb\sample.log
> [INFO] Missing header in: E:\Java\Empire-DB-MVN2\empire-db-parent\empire-db-exam
> ples\empire-db-example-struts2\src\main\webapp\hsqldb\sample.properties
> [WARNING] Unknown file extension: E:\Java\Empire-DB-MVN2\empire-db-parent\empire
> -db-examples\empire-db-example-struts2\src\main\webapp\WEB-INF\empire-tags.tld
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Some files do not have the expected license header
> [INFO] ------------------------------------------------------------------------
>
> However I don't know where to configure the license check.

That hsqldb folder must be generated by eclipse when starting the app,
it should not be placed in that webapp sources folder but rather
somewhere in the target folder or somewhere else.

So the solution is to make sure no database is created in src.

The dirty solution would be add it to to svn ignore and add a filter
to the header check in the parent pom.xml. Search for
com.google.code.maven-license-plugin and add
<excludes><exclude>....</exclude></excludes>

Francis

>
> Has anyone got any ideas how to resolve any of these problems?
>
> Regards
> Rainer
>
>
>



-- 
http://www.somatik.be
Microsoft gives you windows, Linux gives you the whole house.

Mime
View raw message