incubator-empire-db-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francis De Brabandere <franci...@gmail.com>
Subject Re: Review of release assembly
Date Tue, 07 Apr 2009 22:09:34 GMT
>> Another question to Francis:
>> When I tried to run the struts2 samples I had another problem. When I chose "Debug
on Server" for the empire-db-example-struts2 (using Tomcat 5.5.) I get the following error
in the log:
>>  java.lang.NoClassDefFoundError: org/apache/log4j/xml/DOMConfigurator
>> For some reason log4j is not published to the WEB-INF/lib directory although it seems
to be correctly specified as a maven dependency. Do you have any idea why other maven depedencies
are copyied and this one is not?
>
> i'll fix this


I added log4j in the struts2 example dependencies

the struts2-cxf example seems to be using slf4j-jdk logging, I suppose
it needs log4j as well (might be better to use slf4j-log4j then)?

>
>> On the other hand the servlet-api-2.4.jar and jsp-api-2.0.jar are published although
they should not.
>> (Personally I am using the sysdeo tomcat plugin with which the examples run fine
when configured correctly)
>
> i should be able to fix this as well
>

this depends on the scope of the dependency: see
http://maven.apache.org/guides/introduction/introduction-to-dependency-mechanism.html#Dependency_Scope
fixed, put them to scope "provided" (in parent pom dep management)


please check if both are ok now

-- 
http://www.somatik.be
Microsoft gives you windows, Linux gives you the whole house.

Mime
View raw message