incubator-drill-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darion Yaphet <darion.yap...@gmail.com>
Subject Re: can't connect to hbase
Date Thu, 05 Jun 2014 11:05:55 GMT
Just guess
You select from  INFORMATION_SCHEMA.SCHEMATA




2014-06-05 18:54 GMT+08:00 Lulu Prat <luluprat@gmail.com>:

> i don't understand wath you say ?
>
>
> 2014-06-05 12:43 GMT+02:00 darion <darion.yaphet@gmail.com>:
>
> > It not the hbase's table  it seems like the drill data source
> >
> > darion.yaphet
> >
> > 于 14-6-5 下午6:34, Lulu Prat 写道:
> >
> >  hello
> >>
> >> i am triing to use drill with an existing hbase table.
> >>
> >> i try
> >> ./bin/sqlline -u jdbc:drill:schema=hbase -n admin -p admin
> >> sqlline version 1.1.6
> >> 0: jdbc:drill:schema=hbase>SELECT SCHEMA_NAME AS Database FROM
> >> INFORMATION_SCHEMA.SCHEMATA;
> >> +------------+
> >> |  Database  |
> >> +------------+
> >> | dfs.default |
> >> | dfs.root   |
> >> | dfs.tmp    |
> >> | cp.default |
> >> | hbase      |
> >> | sys        |
> >> | INFORMATION_SCHEMA |
> >> +------------+
> >> 7 rows selected (0,828 seconds)
> >>
> >>
> >> there is no hbase table.
> >>
> >> i configure this way :
> >> hbase : {
> >>        type:"hbase",
> >>        config : {
> >>          "hbase.zookeeper.quorum" : "localhost",
> >>          "hbase.zookeeper.property.clientPort" : 2181
> >>        }
> >>      }
> >>
> >> i use cloudera CDH5
> >> zookeeper is working
> >>
> >>
> >> So wath's wrong ??
> >>
> >> thanks for your help
> >>
> >> Lucile
> >>
> >>
> >
>



-- 


long is the way and hard  that out of Hell leads up to light

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message