incubator-drill-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Darion Yaphet <darion.yap...@gmail.com>
Subject Re: Problem compiling code
Date Tue, 03 Jun 2014 08:25:10 GMT
Nice ! :)


2014-06-03 4:30 GMT+08:00 Renato Marroquín Mogrovejo <
renatoj.marroquin@gmail.com>:

> Solved, and posting in here if any body else encounters this in the future.
> The problem lies in the pom.xml file of
> incubator-drill/contrib/data/tpch-sample-data as it makes reference to a
> 1.2.0-SNAPSHOT which doesn't exist. If this is changed into 1.2.0 then the
> error goes away and we can live happily ever after.
>
>  29      <plugin>
>  30         <groupId>com.googlecode.maven-download-plugin</groupId>
>  31         <artifactId>download-maven-plugin</artifactId>
>  32         <version>1.2.0</version>
>  33         <executions>
> ...
>
> Should I open a JIRA for this? Could anybody confirm this? Thanks!
>
>
> Renato M.
>
>
> 2014-06-02 22:20 GMT+02:00 Renato Marroquín Mogrovejo <
> renatoj.marroquin@gmail.com>:
>
> > Not being able to find such JAR in:
> >
> >
> >
> https://oss.sonatype.org/content/groups/public/com/googlecode/maven-download-plugin/download-maven-plugin/1.2.0-SNAPSHOT/
> >
> > makes sense because it is not there. Any suggestions are welcome (:
> >
> >
> > 2014-06-02 22:08 GMT+02:00 Renato Marroquín Mogrovejo <
> > renatoj.marroquin@gmail.com>:
> >
> > My new settings.xml looks like this:
> >>
> >> <settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"   xmlns:xsi="
> >> http://www.w3.org/2001/XMLSchema-instance"   xsi:schemaLocation="
> >> http://maven.apache.org/SETTINGS/1.0.0
> >> http://maven.apache.org/xsd/settings-1.0.0.xsd">
> >>
> <localRepository>/Users/renatomarroquin/.m2/repository</localRepository>
> >>   <interactiveMode>true</interactiveMode>
> >>   <usePluginRegistry>false</usePluginRegistry>
> >>   <offline>false</offline>
> >>   <pluginGroups/>
> >>   <servers/>
> >>   <mirrors/>
> >>   <proxies/>
> >>   <profiles/>
> >>   <activeProfiles/>
> >> </settings>
> >>
> >> But I keep on getting the same error.
> >>
> >> @Darion
> >> Thanks for the comment, but which one should/could I use instead?
> >>
> >>
> >> Renato M.
> >>
> >>
> >> 2014-06-02 14:10 GMT+02:00 Darion Yaphet <darion.yaphet@gmail.com>:
> >>
> >> Maybe  need to change a new maven repo source :)
> >>>
> >>>
> >>> 2014-06-02 18:12 GMT+08:00 Renato Marroquín Mogrovejo <
> >>> renatoj.marroquin@gmail.com>:
> >>>
> >>> > Thanks for your answer Ramana! But that didn't work.
> >>> > I have realized that I haven't got an ~/.m2/settings.xml file set up.
> >>> Do I
> >>> > need to set up special configurations for installing Drill?
> >>> >
> >>> >
> >>> > Renato M.
> >>> >
> >>> >
> >>> > 2014-06-02 6:18 GMT+02:00 Ramana Inukonda <rinukonda@maprtech.com>:
> >>> >
> >>> > > Can you try a mvn clean install -U
> >>> > > Also, if that does not work can you share your settings.xml?
> >>> > > On Sunday, June 1, 2014, Renato Marroquín Mogrovejo <
> >>> > > renatoj.marroquin@gmail.com> wrote:
> >>> > >
> >>> > > > Hi,
> >>> > > >
> >>> > > > I am trying to compile the code, I have checked it out from
the
> git
> >>> > repo
> >>> > > > and tried "mvn clean install -DskipTests" but I am getting:
> >>> > > >
> >>> > > > [ERROR] Plugin
> >>> > > >
> >>> >
> >>>
> com.googlecode.maven-download-plugin:download-maven-plugin:1.2.0-SNAPSHOT
> >>> > > > or one of its dependencies could not be resolved: Failure
to find
> >>> > > >
> >>> > > >
> >>> > >
> >>> >
> >>>
> com.googlecode.maven-download-plugin:download-maven-plugin:jar:1.2.0-SNAPSHOT
> >>> > > > in https://oss.sonatype.org/content/groups/public was cached
in
> >>> the
> >>> > > local
> >>> > > > repository, resolution will not be reattempted until the
update
> >>> > interval
> >>> > > of
> >>> > > > sonatype-public-repository has elapsed or updates are forced
->
> >>> [Help
> >>> > 1]
> >>> > > >
> >>> > > > At the [INFO] contrib/data/tpch-sample-data .....................
> >>> > FAILURE
> >>> > > > [  0.053 s]
> >>> > > > When I run mvn -version, I get this:
> >>> > > >
> >>> > > > Apache Maven 3.2.1 (ea8b2b07643dbb1b84b6d16e1f08391b666bc1e9;
> >>> > > > 2014-02-14T18:37:52+01:00)
> >>> > > > Maven home:
> >>> > > > /Users/renatomarroquin/Documents/Apache/Maven/apache-maven-3.2.1
> >>> > > > Java version: 1.7.0_51, vendor: Oracle Corporation
> >>> > > > Java home:
> >>> > > >
> /Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk/Contents/Home/jre
> >>> > > > Default locale: en_US, platform encoding: UTF-8
> >>> > > > OS name: "mac os x", version: "10.9.2", arch: "x86_64", family:
> >>> "mac"
> >>> > > >
> >>> > > > I thought this was the same as
> >>> > > > https://issues.apache.org/jira/browse/DRILL-492 but everything
> >>> seems
> >>> > > > alright on my environment. Could you please help me with
this
> >>> error?
> >>> > > > Thanks!
> >>> > > >
> >>> > > >
> >>> > > > Renato M.
> >>> > > >
> >>> > >
> >>> >
> >>>
> >>>
> >>>
> >>> --
> >>>
> >>>
> >>> long is the way and hard  that out of Hell leads up to light
> >>>
> >>
> >>
> >
>



-- 


long is the way and hard  that out of Hell leads up to light

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message