incubator-drill-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Antelman <eantel...@gmail.com>
Subject Re: Starting out #2
Date Tue, 24 Dec 2013 15:40:11 GMT
Aggh, crap #2 got send when I habitually used emacs binding in Gmail.
In the end the issue is:
1) On both platforms I am seeing RunSimplePlan test failures on all but the
joinTests.
I believe now this is not likely the environment or the master Vs.
Milestone 1.

Sorry for the embarrasing list spam.


On Tue, Dec 24, 2013 at 10:35 AM, Erik Antelman <eantelman@gmail.com> wrote:

> (I submitted this through the website before I had subscribed, so I
> apologize in advance if this is a duplicate. I do have some additional info
> though. So the previous message is superseeded by this.
>
> Hi, and I am new here, excited and wanting the Mongo Storage engine soon
> and maybe willing to help on something.
>
> I have been working on both Windows/Linux (RHEL6) platforms. I have been
> trying to follow the devleopment environment instructions on both platforms
> with a freshly updated Kepler/M2E eclipse.
>
> With Milestone 1:
> I was having rat check failures, which I could pass the ignoreErrors=true
> to get past. On Windows I was having toruble with protoc not being utilized
> (it was available on the cmd line)
>
>
> I was having some trouble with both rat checks and
>    goal com.github.igor-petruk.protobuf:protobuf-maven-plugin:0.6.3:run
> (default) on project common: 'protoc' failed. (Windows)
> on milestone 1.0.0 branch from github.
>
> I did have a complete No failure mvn install on RedHat ELH6 once I ignored
> rat checks.
>
> SO I went with the master (@ 4a83dae35) Sun Dec 1 20:11:27 2013 -0800
> Which both mvn installed and m2e fairly well.
>
> So I tried the reference simple_plan executor instruction  and lo found no
> output, in fact it seemed like the plan graph was not interpreted at all.
> So I got a little brave (foolish) and run the RunSimplePlan test:
>
> org.apache.drill.exec.ref.RunSimplePlan
> flattenPlan(org.apache.drill.exec.ref.RunSimplePlan)
> java.lang.AssertionError: expected:<0> but was:<1>
>
> at
> org.apache.drill.exec.ref.RunSimplePlan.flattenPlan(RunSimplePlan.java:72)
> [...]
> parseSimplePlan(org.apache.drill.exec.ref.RunSimplePlan)
> java.lang.AssertionError: expected:<0> but was:<1>
>
> at
> org.apache.drill.exec.ref.RunSimplePlan.parseSimplePlan(RunSimplePlan.java:47)
>
> I am not sure why I didn't see this failure on the initial root maven
> install. I did see two errors about a tmp file system issue (being on
> windows I thought nothing special of that)
>
> But, I wanted to step around in the debugger, and since the joinPlan
> worked, I thought why not make the simplePlan.json *not* a sequence. Lo it
> worked!
> This seems rather fundamental, so I doubt my environment.
> Any confirmation? Ideas? Questions?
>
>
> --
> for(;;); /* eantelman@gmail.com */
>



-- 
for(;;); /* eantelman@gmail.com */

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message