incubator-deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "marios@redhat.com" <mandr...@redhat.com>
Subject Re: Update dependencies, .gemspec Gemfile rc2
Date Tue, 20 Sep 2011 06:49:40 GMT
On 12/09/11 14:45, marios@redhat.com wrote:
> Attempt #2 at fixing the dependency situation. As with original patch, .gemspec is now
self contained with everything you need to actually run deltacloud (including the cloud provider
gems). Gemfile now includes the gemspec, and adds the dependencies for developers. I like
the division:  .gemspec is 'runtime' and Gemfile is 'development'.
> Difference in this patch is that the dependencies are for ruby 1.8.7 - supporting ruby
1.8.6 is no longer feasible - too many gems are dropping support for this and trying to constrain
gem versions was too unstable.
>
> So to install deltacloud as a user 'sudo gem install deltacloud-core' will get you everything
you need to work with all cloud providers. To develop, 'bundle install --system' will get
you everything in the .gemspec, as well as the development deps in the Gemfile.
>
> With this in mind please check that the versions here are sane - nothing exploding/complaining/broken.
If happy, I commit and then our the next gem we release (in theory 0.4 soon) will come with
'everything' (ie gem install will give users all dependencies),
>
> marios


<review_nag>
please can someone check the sanity of these... we are blocking on 
pushing the new docs out to the website until these dependencies (and a 
new rubygem with this .gemspec) are pushed
</review_nag>

Mime
View raw message