incubator-deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Lalancette <clala...@redhat.com>
Subject Re: [PATCH core 1/2] DTACLOUD-67: Fixed wrong param handling in UI when user want to create a new firewall rule
Date Wed, 17 Aug 2011 12:49:45 GMT
On 08/17/11 - 02:40:23PM, Michal Fojtik wrote:
> On Aug 17, 2011, at 2:19 PM, Chris Lalancette wrote:
> 
> > On 08/17/11 - 11:24:37AM, mfojtik@redhat.com wrote:
> >> From: Michal Fojtik <mfojtik@redhat.com>
> >> 
> >> 
> >> Signed-off-by: Michal fojtik <mfojtik@redhat.com>
> >> ---
> >> server/server.rb                          |    3 +--
> >> server/views/firewalls/new_rule.html.haml |    2 +-
> >> 2 files changed, 2 insertions(+), 3 deletions(-)
> > 
> > I tried out this patch (and the next one) locally, but they don't seem to fix
> > the problem.  First, I still get the problem where the "create firewall" page
> > doesn't refresh properly.  Second, the "create firewall rule" page no longer
> > throws an error, but it also doesn't seem to properly create the rule on the
> > backend security group either.
> 
> Did you set correct source address? Like 0.0.0.0/0 into address field?
> Otherwise new rule is advertised as 'created' but in fact it's not since
> you need to specify this address.

Yeah, I tried it both with and without the source address, as I've noticed the
same thing.  Both cases did not work for me.

> 
> I'm going to fill out a bug for this. It would be great to have 'address' field
> as 'required'.
> 
> Create firewall page is not refreshed because the firewall is creating using AJAX.
> This can be disabled by:
> 
>   - %form{ :action => firewalls_url, :method => :post }
>   + %form{ :action => firewalls_url, :method => :post, :'data-ajax' => 'false'
}

This on top of your other patches did fix the refresh problem for me.

Thanks,
-- 
Chris Lalancette

Mime
View raw message