incubator-deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark McLoughlin <mar...@redhat.com>
Subject [PATCH 1/3] Client: don't require lib/base_object
Date Thu, 18 Aug 2011 08:51:49 GMT
client/lib/deltacloud.rb was recently changed to require 'lib/base_object'
rather than 'base_object' which results in:

  $ irb -rubygems
  irb(main):001:0> require 'deltacloud'
  LoadError: no such file to load -- lib/base_object
    from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
    from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
    from /usr/lib/ruby/gems/1.8/gems/deltacloud-client-0.4.0/lib/deltacloud.rb:26
    from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:59:in `gem_original_require'
    from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:59:in `require'
    from (irb):1

When you load a gem, 'lib' is automatically included in the load path.
---
 client/lib/deltacloud.rb |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/client/lib/deltacloud.rb b/client/lib/deltacloud.rb
index 258a48f..782f926 100644
--- a/client/lib/deltacloud.rb
+++ b/client/lib/deltacloud.rb
@@ -23,7 +23,7 @@ require 'logger'
 require 'hwp_properties'
 require 'instance_state'
 require 'documentation'
-require 'lib/base_object'
+require 'base_object'
 require 'client_bucket_methods'
 
 module DeltaCloud
-- 
1.7.4.4


Mime
View raw message