incubator-deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Lalancette (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DTACLOUD-36) Load Balancers don't seem to be HATEOS
Date Wed, 04 May 2011 19:35:03 GMT
Load Balancers don't seem to be HATEOS
--------------------------------------

                 Key: DTACLOUD-36
                 URL: https://issues.apache.org/jira/browse/DTACLOUD-36
             Project: DeltaCloud
          Issue Type: Bug
          Components: Server
            Reporter: Chris Lalancette
            Assignee: David Lutterkort


When fetching the XML related to a load balancer, it looks like this:

<load_balancers>
  <load_balancer href="http://localhost:3001/api/load_balancers/my-load-balancer" id="my-load-balancer">
    <actions>
      <link href="http://localhost:3001/api/load_balancers/my-load-balancer" method="delete"
rel="destroy"/>
    </actions>
    ...
  </load_balancer>
</load_balancers>

What you'll notice about the <actions> section is that it is missing a link to "register"
a new instance with this load_balancer.  In order to be fully HATEOS, I would expect the XML
above to have an action similar to:

<link href="http://localhost:3001/api/load_balancers/my-load-balancer/register" method="post"
rel="register"/>

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message