incubator-deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Guiditta <jason.guidi...@gmail.com>
Subject Error with auth on ec2 using latest trunk
Date Mon, 18 Apr 2011 21:11:25 GMT
This may just be something simple, I'll be digging into this more tomorrow,
but I wanted to ask here first in case it is a well known or easily solved
problem.  When I try to view a list of images for ec2 (directly from
browser, hitting api/images) and try to provide my credentials, I get an
error/stack trace.  I can provide the full trace if needed, but the part
that seems interesting is that I get the following error directly from ec2
if I put in the url shown on the core error page:

<Response>
−
<Errors>
−
<Error>
<Code>SignatureDoesNotMatch</Code>
−
<Message>
The request signature we calculated does not match the signature you
provided. Check your AWS Secret Access Key and signing method. Consult the
service documentation for details.
</Message>
</Error>
</Errors>
<RequestID>18a63fbc-bf29-4846-9b2b-bb47a92a3711</RequestID>
</Response>

Signing method shown in url is:
SignatureMethod=HmacSHA256&SignatureVersion=2

This happens with a known good access key/private key that worked moments
earlier on version 0.2.0.  Any quick pointers, maybe a bad version of a dep
or something?  I'll provide more info if needed tomorrow, just thought I'd
do a quick check here before I went to far in my own investigation.
 Thanks,

-j

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message