incubator-deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Woods <woods...@gmail.com>
Subject Re: IBM SBC Driver Available
Date Thu, 10 Feb 2011 15:59:52 GMT
David, I am able to run the cucumber tests from your advice below.  However, I'm still unable
to run the unit tests even after installing rspec (version 2.5.0) via "sudo gem install rspec"
 Same error: "no such file to load -- spec (LoadError)"

I see within server/Rakefile that "spec" is initialized as "spec = Gem::Specification.load('deltacloud-core.gemspec')"
 Could this be inaccessible to the tests or not run at all when running "rake test" from the
server directory?

Here's the full message:
(in /Users/Eric/Development/workspace/deltacloud/110128_1718_deltacloud/server)
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby -I"lib" "/Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader.rb"
"tests/drivers/mock/api_test.rb" "tests/drivers/mock/hardware_profiles_test.rb" "tests/drivers/mock/images_test.rb"
"tests/drivers/mock/instance_states_test.rb" "tests/drivers/mock/instances_test.rb" "tests/drivers/mock/realms_test.rb"
"tests/drivers/mock/url_for_test.rb" "tests/rabbit_test.rb" 
warning: Insecure world writable dir /Users/Eric in PATH, mode 040777
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require': no such file to load -- spec (LoadError)
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
`require'
	from ./tests/drivers/mock/../../../tests/common.rb:6
	from ./tests/drivers/mock/api_test.rb:2:in `require'
	from ./tests/drivers/mock/api_test.rb:2
	from /Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader.rb:5:in `load'
	from /Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader.rb:5
	from /Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader.rb:5:in `each'
	from /Library/Ruby/Gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader.rb:5
rake aborted!
Command failed with status (1): [/System/Library/Frameworks/Ruby.framework/...]

Thanks for your help,
- Eric W.


On Feb 7, 2011, at 7:05 PM, David Lutterkort wrote:

> On Mon, 2011-02-07 at 17:15 -0500, Eric Woods wrote:
>> I've updated the patch to address your comment (https://issues.apache.org/jira/browse/DTACLOUD-15).
 The driver should be complete and ready to be committed.
>> 
>> Now I'm turning my attention to tests.  I'm running into issues when running either
test set:
>> 
>> 1) When I run "rake test" within the server directory, I get no
>> output.  After inspecting server/Rakefile, I changed the test
>> FileList.new(...) to "t.test_files =
>> FileList.new('tests/**/**/*_test.rb')" to pull in the "mock"
>> directory.  This triggers common.rb to execute, but I then receive a
>> LoadError for "spec."  I can't find this gem installed locally or 
> 
> The tests pass for me without any changes to the Rakefile (IIRC, '**'
> matches directory hierarchies of arbitrary depths)
> 
> 
>> remotely.  I'm trying to install it via "sudo gem install spec."
> 
> The gem is cleverly called 'rspec'
> 
>> 2) When I run "API_DRIVER={ec2, mock} rake cucumber" within top level
>> tests, the rake aborts from not being able to load "rack/test"
> 
> You need to 'gem install rack-test'. There's a Gemfile that should list
> all the dependencies (look in the :test section) If anything is missing
> from that list, we need to add it.
> 
>> Only ec2, mock, and rhevm are supported for cucumber tests, and only
>> mock is supported for the unit tests.  Have these tests been updated
>> recently and we know they should run?  Of course I'm new to ruby, so I
>> could be making a trivial mistake.
> 
> Yes, all those tests pass for me - clearly, we need to document the
> process of setting up a dev environment better. If you still have it,
> can you collect a list of the gems you had to install for this
> exercise ? We need to make sure it goes into the Gemfile and the
> gemspec.
> 
> David
> 
> 


Mime
View raw message