incubator-deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Fojtik <mfoj...@redhat.com>
Subject Re: Server returns JSON, not HTML
Date Thu, 13 Jan 2011 09:57:08 GMT
On 12/01/11 15:35 -0800, David Lutterkort wrote:
>On Wed, 2011-01-12 at 14:31 -0500, Eric Woods wrote:
>> I'm trying to access the Deltacloud's HTML front-end for the mock &
>> EC2 drivers.  After starting the server and pointing my browser to
>> http://localhost:3001/api, the server only returns the JSON API, not
>> HTML.  I'm currently running on Mac OSX.  Interestingly, when I
>> installed Deltacloud on a Windows 7 machine this morning, HTML was
>> served as expected.  Any ideas what could cause this?
>
>Is this with Safari ? I remember darkly that webkit has a rather
>interesting choice for its default Accept header, which makes it not all
>that useful for content negotiation[1]

Well we tested it right now using Safari 5 on MacOSX and it returns HTML.
Could you please debug it more for us ?

   -- Michal

>
>You can force that HTML be sent back by appending '?format=html' to each
>URL. Not sure if there's a way to fix the Safari Accept header to
>something sensible.
>
>David
>
>[1] http://www.gethifi.com/blog/webkit-team-admits-accept-header-error has the
>    gory details. Also see https://bugs.webkit.org/show_bug.cgi?id=27267
>
>

-- 
--------------------------------------------------------
Michal Fojtik, mfojtik@redhat.com
Deltacloud API: http://deltacloud.org
--------------------------------------------------------

Mime
View raw message