incubator-deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Toby Crawley <tcraw...@redhat.com>
Subject Re: Initial EC2 driver rewrite (rev 1)
Date Sat, 13 Nov 2010 04:11:58 GMT
On 11/12/2010 11:12 AM, marios@redhat.com wrote:
> Hi Michal, I just did some really quick and dirty testing for this - I was mostly interested
to see if they solved the regions issue with
> the new gem... but I didn't get that far.
>
> The patches apply fine but when I run I am getting lots of errors...
>
> Get /images gives:
>
> "
> ##### Aws::Ec2 returned an error: 400 Bad Request
> <?xml version="1.0" encoding="UTF-8"?>
> <Response><Errors><Error><Code>UnknownParameter</Code><Message>The
parameter ImageType is not
> recognized</Message></Error></Errors><RequestID>93f59b50-d36d-4416-a90a-0d0dfd423f8c</RequestID></Response>
#####
> "
>

 From the client, images returns 88 images. If I pass an empty string as the owner_id (to
override the default owner_id of 'amazon'), the 
request times out before completing. I'll try it from the ui.

>
> Get /buckets gives:
> "
> #<ArgumentError: wrong number of arguments (2 for 1)>
> " (+ huge stack trace)
>

This looks like a bug in the aws gem. They have pulled a few things out of ActiveSupport that
they need, but only load them if ActiveSupport 
is loaded. Unfortunately, the constantize method relies on a version of const_get with an
arity of two, which may be defined elsewhere in 
ActiveSupport (https://github.com/appoxy/aws/blob/master/lib/awsbase/support.rb#L49). The
const_get in both ruby 1.8.6 & 1.8.7 as an arity 
of one - I did not check 1.9. Michal: what version of ruby are you running? Is it possible
that ActiveSupport is getting loaded for you for 
some reason?

I've tested the snapshot and storage volume support, and it is working. I've got the actions
support for storage volumes mostly done - just 
a little more testing to do. I'll try to finish that up over the weekend.

Toby







Mime
View raw message