incubator-deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Browning <bbrow...@redhat.com>
Subject [PATCH 0/2] Deltacloud Client JRuby Compatibility
Date Wed, 25 Aug 2010 19:07:29 GMT
The following two patches are the steps I had to take to
get deltacloud-client running properly under JRuby.

The output of the 'rake package' task now produces two
gems - deltacloud-client-x.x.x.x-java.gem and
deltacloud-client-x.x.x.x.gem.

The JRuby gem depends on Nokogiri 1.5.0.beta.2 because
that is the earliest version with a pure-Java (no FFI)
implementation.

Ben Browning (2):
  Fix authorization header encoding under JRuby
  Build java and ruby versions of client gem

 client/Rakefile                  |   11 +++++++++--
 client/deltacloud-client.gemspec |   10 ++++++++--
 client/lib/deltacloud.rb         |    6 +++++-
 3 files changed, 22 insertions(+), 5 deletions(-)

-- 
1.7.2.1


Mime
View raw message