incubator-deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Guiditta <jason.guidi...@gmail.com>
Subject Re: [PATCH core] Fixed rest-client 1.6.0 incompatibility for deltacloud client
Date Thu, 15 Jul 2010 16:36:14 GMT
fyi, changing the two instances of '&block' to 'block' seems to fix the
errors, so
 RestClient.send(:post, conf[:path], conf[:form_data], default_headers) do
|response, request, &block|
becomes
 RestClient.send(:post, conf[:path], conf[:form_data], default_headers) do
|response, request, block|

and same for the other one.

On Thu, Jul 15, 2010 at 11:55 AM, Jason Guiditta
<jason.guiditta@gmail.com>wrote:

> This fails for me with:
>
> /usr/lib/ruby/gems/1.8/gems/deltacloud-client-0.0.6/lib/deltacloud.rb:311:
> warning: else without rescue is useless
> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require':
> /usr/lib/ruby/gems/1.8/gems/deltacloud-client-0.0.6/lib/deltacloud.rb:297:
> syntax error, unexpected tAMPER, expecting '|' (SyntaxError)
> ...ders) do |response, request, &block|
>                               ^
> /usr/lib/ruby/gems/1.8/gems/deltacloud-client-0.0.6/lib/deltacloud.rb:305:
> syntax error, unexpected tAMPER, expecting '|'
> ...ders) do |response, request, &block|
>                               ^
> /usr/lib/ruby/gems/1.8/gems/deltacloud-client-0.0.6/lib/deltacloud.rb:379:
> syntax error, unexpected kEND, expecting $end
>  from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `require'
> from
> /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
> `require'
>  from
> /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:521:in
> `new_constants_in'
> from
> /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
> `require'
>  from
> /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:208:in
> `load'
> from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:307:in
> `load_gems'
>  from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:307:in
> `each'
> from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:307:in
> `load_gems'
>  ... 15 levels...
> from /usr/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/commands/server.rb:78
>  from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require'
> from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
>  from ./script/server:3
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message