incubator-ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Halgrim, Scott" <halgri...@ghc.org>
Subject RE: install cTAKES, Maven, proxy
Date Wed, 06 Feb 2013 20:49:50 GMT
I'm pretty sure that's not the issue. I actually tried this again on Tuesday and things started
fine, but I eventually ran into problems.

Now the problem is that it runs through the 'Checking out Maven projects' step until it gets
to about 46% (gradually slows down throughout this process), then it moves on to Importing
Maven projects and errors start popping up. It gets to 74% on that step, then moves on to
Building workspace which gives me more errors.

I'm getting build errors like:
Project build error: Non-resolvable parent POM: Failure to transfer org.apache:apache:pom:11
from http://repo.maven.apache.org/maven2 was cached in the local repository, resolution will
not be reattempted until the update interval of central has elapsed or updates are forced.
Original error: Could not transfer artifact org.apache:apache:pom:11 from/to central (http://repo.maven.apache.org/maven2):
NullPointerException and 'parent.relativePath' points at wrong local POM

And it's unable to resolve a bunch of imports, like import opennlp.*

My attempts to fix this have been combinations of 
1) Delete projects in Eclipse and re-import
2) Clear out .m2\repository folder
3) Copy .m2\setings.xml from private drive to .m2\ folder on C drive, which is a no-no here
anyway since the C drive isn't as secure as the private network drive and I have to put my
proxy password in plaintext in the settings file.

Thanks,

Scott

-----Original Message-----
From: Chen, Pei [mailto:Pei.Chen@childrens.harvard.edu] 

You wouldn't happen to be running NTLM proxy and mvn 3.0.4 would you?
http://jira.codehaus.org/browse/MNG-5237


> -----Original Message-----
> From: Halgrim, Scott [mailto:halgrim.s@ghc.org]

> 
> Appreciate the earlier post on the settings.xml file as the place to address
> proxy issues when importing Maven projects. But I still got stuck. I've sent
> some e-mail around internally trying to get some GH eyeballs on the issue,
> but thought I'd hit up this list, too, to see if anybody else can figure out why
> I'm getting a proxy authentication error when I try to import the Maven
> projects into my workspace.
> 
> Here's my settings.xml file.
> 
> <settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
>                           xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>                           xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
> http://maven.apache.org/xsd/settings-1.0.0.xsd">
>  <proxies>
>   <proxy>
>    <id>ghc_proxy</id>
>    <active>true</active>
>    <protocol>http</protocol>
>    <host>proxyserver.ghc.org</host>
>    <port>8080</port>
>    <username>domain\\halgsr1</username>
>    <password>REDACTED</password>
>    <nonProxyHosts>localhost|127.0.0.1</nonProxyHosts>
>   </proxy>
>  </proxies>
> </settings>
> 
> 
> I have also tried these replacements for the host-password lines
> 
> ***
>    <host>anotherserver.ghc.org/proxy.pac</host>
>    <port>80</port>
> ***
>    <host>proxyserver.ghc.org</host>
>    <port>8080</port>
>    <username>halgsr1</username>
>    <password>REDACTED</password>
> ***
>    <host>proxyserver.ghc.org</host>
>    <port>8080</port>
>    <username>domain\halgsr1</username>
>    <password>REDACTED</password>
> ***
> 
> Thanks,
> 
> Scott
> 
> 
> ________________________________
> 
> GHC Confidentiality Statement
> 
> This message and any attached files might contain confidential information
> protected by federal and state law. The information is intended only for the
> use of the individual(s) or entities originally named as addressees. The
> improper disclosure of such information may be subject to civil or criminal
> penalties. If this message reached you in error, please contact the sender
> and destroy this message. Disclosing, copying, forwarding, or distributing the
> information by unauthorized individuals or entities is strictly prohibited by
> law.

Mime
View raw message