incubator-ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy McMurry <mcmurry.a...@gmail.com>
Subject Re: cTAKES 3.0 developer guide review
Date Wed, 13 Feb 2013 08:50:01 GMT
Suggestion: 

"Apache cTAKES requires Java level 1.6; it has been tested with Sun Java SDK v6.0, IBM Java
6.0, and OpenJDK 6.0. 
Running the Eclipse plugin tooling for UIMA requires you start Eclipse. 
The supported platforms are: Windows, Linux, Solaris, AIX and Mac OS X.  
Other platforms and Java (1.7 or 1.8) implementations should work, but have not been significantly
tested." 

My idea is simply to adopt/adopt the UIMA "supported platforms" statement specifically for
cTAKES . 
http://svn.apache.org/repos/asf/uima/uimaj/trunk/README

"Apache UIMA requires Java level 1.5; it has been tested with Sun Java SDK v5.0 and v6.0,
and IBM Java 6.0.
Running the Eclipse plugin tooling for UIMA requires you start Eclipse using a Java 1.5 or
later, as well.
The supported platforms are: Windows, Linux, Solaris, AIX and Mac OS X.  
Other platforms and Java (1.5+) implementations should work, but have not been significantly
tested.

Many of the scripts in the /bin directory invoke Java. They use the value of the environment
variable, JAVA_HOME, 
to locate the Java to use; if it is not set, they invoke "java" expecting to find an appropriate
Java in your PATH." 





On Feb 13, 2013, at 12:16 AM, Jörn Kottmann <kottmann@gmail.com> wrote:

> On 02/13/2013 12:38 AM, Andy McMurry wrote:
>> I suggest changing the Java supported versions from "JDK 1.6+" to the UIMA supported
versions (minus JDK 1.5).
>> http://svn.apache.org/repos/asf/uima/uimaj/trunk/README
>> 
>> Worth noting that Java 1.6 is facing end of life and Java 1.8 would likely be very
experimental.
>> (Unless of course cTakes is been thoroughly tested on Java 1.7 and 1.8 )
> 
> Why do you think it should be switched back to 1.5? Java is backward compatible, cTAKES
should
> run fine on 1.7 or 1.8 when its out.
> 
> Do you have to run on 1.5 in your production system?
> 
> Jörn


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message