incubator-ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karthik Sarma <ksa...@ksarma.com>
Subject Re: Failure on unpack-dependencies?
Date Wed, 09 Jan 2013 22:20:23 GMT
I was able to check out the 3.0.0 branch and build + run it without
trouble. Will give the trunk another try





--
Karthik Sarma
UCLA Medical Scientist Training Program Class of 20??
Member, UCLA Medical Imaging & Informatics Lab
Member, CA Delegation to the House of Delegates of the American Medical
Association
ksarma@ksarma.com
gchat: ksarma@gmail.com
linkedin: www.linkedin.com/in/ksarma


On Wed, Jan 9, 2013 at 1:46 PM, Masanz, James J. <Masanz.James@mayo.edu>wrote:

> I did not get this error when I used eclipse's miport feature with maven
> from SCM.
> Everything built fine (The second time I tried a build)
> Note, I did a Maven->Update project... from within eclipse between the two
> builds.
>
> -- James
>
>
> > -----Original Message-----
> > From: ksarma@gmail.com [mailto:ksarma@gmail.com] On Behalf Of Karthik
> > Sarma
> > Sent: Tuesday, January 08, 2013 6:30 PM
> > To: cTAKES Developer List
> > Subject: Failure on unpack-dependencies?
> >
> > Hi folks,
> >
> > I was trying to get the trunk up and running on a new windows 8 machine
> > (completely clean). Installed jdk, eclipse (classic/juno), m2e, and
> > subversive. I used eclipse's import feature with maven from SCM. Checkout
> > was fine, but ctakes-dictionary-lookup was not able to build (as far as I
> > could tell, everything else built just fine. Here is the error:
> >
> > Execution unpack-dependencies of goal
> > org.apache.maven.plugins:maven-dependency-plugin:2.6:unpack-dependencies
> > failed: Plugin org.apache.maven.plugins:maven-dependency-plugin:2.6 or
> one
> > of its dependencies could not be resolved: Failed to collect dependencies
> > for org.apache.maven.plugins:maven-dependency-plugin:jar:2.6 ()
> > (org.apache.maven.plugins:maven-dependency-plugin:2.6:unpack-
> > dependencies:unpack-dependencies:process-resources)
> > pom.xml /ctakes-dictionary-lookup line 82
> >
> > I did a few checks to try to diagnose the issue -- the pom seems to be
> > correct, and the m2e fix for unpack also seems to be correct. The plugin
> > itself (for umls) exists in my local repository, as does
> maven-dependency-
> > plugin 2.6. There aren't any spaces or other oddities in any of the
> paths.
> > I tried cleaning, re-acquiring the source, and even deleting eclipse and
> > starting from scratch, but alas, no dice.
> >
> > Is anyone else having a similar issue? Jenkins says everything should be
> > working fine. I should probably just try building without involving
> > eclipse at all, which I will do next.
> >
> >
> > Karthik
> >
> >
> > --
> > Karthik Sarma
> > UCLA Medical Scientist Training Program Class of 20??
> > Member, UCLA Medical Imaging & Informatics Lab Member, CA Delegation to
> > the House of Delegates of the American Medical Association
> > ksarma@ksarma.com
> > gchat: ksarma@gmail.com
> > linkedin: www.linkedin.com/in/ksarma
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message