incubator-ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Finan, Sean" <Sean.Fi...@childrens.harvard.edu>
Subject RE: Failure on unpack-dependencies? [ctakes-dictionary-lookup problem with rxnorm_index]
Date Fri, 18 Jan 2013 18:49:54 GMT
Yes, it is the Lucene problem re: reading from a jar.  Get rid of that jar from your lib/ and
make certain that your dictionary/lookup/ looks good.

Btw, this is Jira CTAKES-121

-----Original Message-----
From: Chen, Pei [mailto:Pei.Chen@childrens.harvard.edu] 
Sent: Friday, January 18, 2013 1:46 PM
To: <ctakes-dev@incubator.apache.org>
Cc: ctakes-dev@incubator.apache.org
Subject: Re: Failure on unpack-dependencies? [ctakes-dictionary-lookup problem with rxnorm_index]

I wonder if its worth it to update the instructions to just unzip it manually.  Probably more
complicated to try to do it automatically do it with the plugins... 
Or remove the requirement to unpack jars (I think it was a Lucene limitation not be able to
read from a jar file)

Sent from my iPhone

On Jan 18, 2013, at 1:32 PM, "Coarr, Matt" <mcoarr@mitre.org> wrote:

> Tim, did you ever manage to get this working?    Does anyone else have any ideas on this
problem?
> 
> I'm trying to run the full pipeline on the ctakes trunk and I'm running into the same
issue - rxnorm_index isn't found when initializing the dictionary lookup AE.
> 
> I also tried Pei's suggestion of cleaning and rebuilding.  I tried both in eclipse (Project
menu -> "clean...", then choose to clean all the project, and let eclipse automatically
rebuild), and on the command-line ("mvn clean compile" from the root project).
> 
> I'll comment on my attempt from the command-line here...
> 
> I can see that it's trying to extract the dependency for "ctakes-resources-umls2011ab-3.1.0.jar".
 This jar file does have the rxnorm_index in the appropriate location, but the ctakes-dictionary-lookup/target/classes
directory does not have any rxnorm_index directory.  Again, this is true from a clean-then-build
either from eclipse or the command-line.
> 
> Here's a fragment from the maven output (note the line that starts with "Unpacking...").
> 
> Here's the maven output:
> 
> [INFO] 
> ----------------------------------------------------------------------
> -- [INFO] Building Apache cTAKES dictionary lookup 
> 3.1.0-incubating-SNAPSHOT [INFO] 
> ----------------------------------------------------------------------
> --
> [INFO]
> [INFO] --- maven-clean-plugin:2.4.1:clean (default-clean) @ 
> ctakes-dictionary-lookup --- [INFO] Deleting 
> /work/medfacts/apache/svn/apache_trunk/ctakes-dictionary-lookup/target
> [INFO]
> [INFO] --- maven-remote-resources-plugin:1.3:process (default) @ 
> ctakes-dictionary-lookup --- [INFO] [INFO] --- 
> maven-resources-plugin:2.5:resources (default-resources) @ 
> ctakes-dictionary-lookup --- [debug] execute contextualize [INFO] 
> Using 'UTF-8' encoding to copy filtered resources.
> [INFO] Copying 80 resources
> [INFO] Copying 3 resources
> [INFO]
> [INFO] --- maven-dependency-plugin:2.6:unpack-dependencies 
> (unpack-dependencies) @ ctakes-dictionary-lookup --- [INFO] Unpacking /Users/mcoarr/.m2/repository/net/sourceforge/ctakesresources/ctakes-resources-umls2011ab/3.1.0/ctakes-resources-umls2011ab-3.1.0.jar
to /work/medfacts/apache/svn/apache_trunk/ctakes-dictionary-lookup/target/classes with includes
"" and excludes ""
> [INFO]
> [INFO] --- maven-compiler-plugin:2.4:compile (default-compile) @ 
> ctakes-dictionary-lookup --- [INFO] Compiling 58 source files to 
> /work/medfacts/apache/svn/apache_trunk/ctakes-dictionary-lookup/target
> /classes
> 
> Thanks!
> Matt
> 
> From: Tim Miller 
> <timothy.miller@childrens.harvard.edu<mailto:timothy.miller@childrens.
> harvard.edu>>
> Reply-To: 
> "ctakes-dev@incubator.apache.org<mailto:ctakes-dev@incubator.apache.or
> g>" 
> <ctakes-dev@incubator.apache.org<mailto:ctakes-dev@incubator.apache.or
> g>>
> Date: Thursday, January 10, 2013 17:42
> To: 
> "ctakes-dev@incubator.apache.org<mailto:ctakes-dev@incubator.apache.or
> g>" 
> <ctakes-dev@incubator.apache.org<mailto:ctakes-dev@incubator.apache.or
> g>>
> Subject: Re: Failure on unpack-dependencies?
> 
> I'm having some trouble with this issue on trunk using eclipse. When I 
> try to run the default pipeline in the cvd it can't find the rxnorm_index:

Mime
View raw message