incubator-ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen, Pei" <Pei.C...@childrens.harvard.edu>
Subject RE: First documentation pages
Date Tue, 06 Nov 2012 22:14:35 GMT
 > *         Move Getting Started under GENERAL, so it appeals to everyone who
> first sees the site. It will define our users and point them in the right
> direction.
I think the Getting Started section should be extremely simple- something like:
(I think the component diagram/dependency tree should be in the manual or reference appendix
rather than "quick" start guide).

Requirements
-----------
Java 1.6+ is required to run cTAKES

Download
-----------
[Link to the latest download section to apache-ctakes-{release}.tar.gz/.zip] and unzip file.

Running the default pipeline in the UIMA CAS Visual Debugger or Collection Processing Engine
-----------
Run bin/runctakesCVD/CPE.sh.bat
Load AE (analysis engine)
Select desc/ctakes-clinical-pipeline/desc/analysis_engine/AggregatePlaintextProcessor
Enter note(s) and run analysis engine.

Notes
-----------
If you plan to use the UMLS Resources, on can add the umls user info:
Export/set ctakes.umlsuser=[username]
Export/set ctakes.umlspw=[password]
or add the system properties to the java args
-Dctakes.umlsuser=[username] -Dctakes.umlspw=[password]

> Now a question as well. When we went from cTAKES 1.0 to 1.2 we settled on
> calling the parts of cTAKES one can take advantage of "component" as
> evidenced by the diagram created and the documentation section headers,
> etc. In the past month I've seen more people refer to the cTAKES parts as
> "module". I'm not stuck on a name. Perhaps module is more of a maven term
> and we didn't have that before. I have in mind what I like, but as I said it does
> not really matter to me, so long as we are consistent. If we change away
> from "component" the doc we pull over from previous releases will need to
> be modified, also not too big a deal. What do you think?

If we had references to 'component' in the previous documentation, my vote would be to also
keep it as component; 
introducing a new term would probably just add more confusion to users.

--Pei

Mime
View raw message