incubator-ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Coarr, Matt" <mco...@mitre.org>
Subject Re: latest build instructions
Date Tue, 30 Oct 2012 20:54:37 GMT
It was NOT set to "offline".

I did have "do not automatically update dependencies from remote
repositories" checked though. I unchecked that and tried again -- still no
improvement.

I'm sort of latching on to this part of the error message I'm seeing in
ctakes-type-system:

  Plugin org.cleartk:jcasgen-maven-plugin:0.9.3 or one of its dependencies
could not be resolved: Failed to collect dependencies for
org.cleartk:jcasgen-maven-plugin:jar:0.9.3 ()
(org.cleartk:jcasgen-maven-plugin:0.9.3:generate:default:process-resources)

I'm wondering if the problem could be with its dependencies??

The direct dependencies of jcasgen-maven-plugin are (based on looking at
the pom for jcasgen-maven-plugin in my local repo):
 - org.apache.maven:maven-plugin-api:3.0.4
 - org.apache.maven:maven-core:3.0.4
 - org.apache.uima:uimaj-tools:2.4.0
 - org.sonatype.plexus:plexus-build-api:0.0.7
 - (I'm skipping a couple that are in test scope)

Matt


On 2012-10-30 10:46 , "Steven Bethard" <steven.bethard@Colorado.EDU> wrote:

>On Oct 30, 2012, at 3:41 PM, "Coarr, Matt" <mcoarr@mitre.org> wrote:
>> Good idea.  So I closed eclipse, removed my "jcasgen-maven-plugin"
>> directory from my local repo ("rm -r
>> ~/.m2/repository/org/cleartk/jcasgen-maven-plugin/"), started eclipse
>>back
>> up.  Then I tried maven -> update project, selected all projects,
>> proceeded.
>> 
>> Unfortunately, I end up with the same error.
>> 
>> Also, eclipse does find and download that plugin again.
>
>What do you see in Eclipse -> Prefrences -> Maven? Is it possible you
>have it in offline mode?
>
>> When eclipse is building, is there any way to get more detailed
>> information than just the "problem" view?
>
>Not that I know of. Of course, you can double-click on one of the
>problems, but it doesn't give you much more info.
>
>>  When I open a "maven" console,
>> this remains blank.
>> 
>> Whereas, if I do Run As -> Maven BuildÅ  -> set the "goals" to "compile"
>>->
>> run, I can then see the maven output on a console.  And this build is
>> successful BTW.
>
>Sadly, Run As -> Maven Build ... has exactly zero integration with the
>Eclipse IDE as far as I can tell. So this is basically the same as
>running it on the command line.
>
>Steve


Mime
View raw message