incubator-ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Britt Fitch <britt.fi...@gmail.com>
Subject Re: Eclipse, Maven and JCasGen
Date Mon, 08 Oct 2012 23:36:51 GMT
I am in the process of getting my cTAKES environment up and running
and I am experiencing the same build automatically issue *sometimes*.
Initially I created a new workspace using Eclipse Helios and it was
causing the constant build unless I shut off Build Automatically.

I downloaded Eclipse Juno and experienced the same issue, however, if
I shut off Build Automatically and then turn it back on without making
any other changes it appears to prevent the issue. It may happen that
this would start up again if I made any code changes though. I am
still trying to reliably reproduce it or complete my environment
setup, whichever comes first. I will update with more details as I get
them.

Thanks

Britt

On Mon, Oct 8, 2012 at 7:21 PM, Chen, Pei
<Pei.Chen@childrens.harvard.edu> wrote:
> Cool.  But, could I suggest we leave the Jira open for at least a few releases? Would
like to try out a few more things, see if other developers are experiencing the same, as I
think it was a nice feature to have jcasgen done automatically within eclipse IDE.
>
> Sent from my iPad
>
> On Oct 8, 2012, at 6:55 PM, "Masanz, James J." <Masanz.James@mayo.edu> wrote:
>
>> I like the switch to <ignore/> as a temporary work around at least. I'm not
opposed to a maven plugin myself, but I don't know enough about maven yet to have a well informed
opinion.
>>
>> I do my cTAKES development in a separate workspace; I see what a pain it would be
to turn off Build Automatically in a shared workspace.
>>
>> -- James
>>
>>
>>> -----Original Message-----
>>> From: ctakes-dev-return-530-Masanz.James=mayo.edu@incubator.apache.org
>>> [mailto:ctakes-dev-return-530-Masanz.James=mayo.edu@incubator.apache.org]
>>> On Behalf Of Steven Bethard
>>> Sent: Monday, October 08, 2012 3:10 PM
>>> To: ctakes-dev@incubator.apache.org
>>> Subject: Re: Eclipse, Maven and JCasGen
>>>
>>> On Oct 6, 2012, at 8:53 PM, Steven Bethard <Steven.Bethard@Colorado.EDU>
>>> wrote:
>>>> If people are opposed to doing it the way m2e suggests (writing a
>>> jcasgen-maven-plugin and a connector, as is done in my patch), then I
>>> think the only alternative would be to use <ignore/> instead of <execute/>
>>> so that JCasGen never runs in Eclipse.
>>>
>>> I've just confirmed that switching <execute/> to <ignore/> stops
the
>>> constant re-building. Of course, it also disables JCasGen generation of
>>> Java sources, which you have to do manually (e.g. by running `mvn compile`
>>> from the command line).
>>>
>>> Steve
>>>
>>> P.S. I also did a completely fresh install of Eclipse and the plugins, and
>>> I still get the same non-stop "Compiling .../target/generated-sources/..."
>>> messages.

Mime
View raw message