incubator-ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Bethard <steven.beth...@Colorado.EDU>
Subject Re: build problem
Date Thu, 11 Oct 2012 14:52:22 GMT
On Oct 11, 2012, at 8:38 AM, Dmitriy Dligach <dmitriy.dligach@childrens.harvard.edu>
wrote:
> I tried that. The quick fix tries to install buildhelper but fails with 
> this message:
> 
> Operation details
> Cannot complete the install because one or more required items could not 
> be found.
> Software currently installed: Shared profile 1.0.0.1349710786867 
> (SharedProfile_epp.package.java 1.0.0.1349710786867)
> Missing requirement: Shared profile 1.0.0.1349710786867 
> (SharedProfile_epp.package.java 1.0.0.1349710786867) requires 
> 'org.maven.ide.eclipse [1.0.200.20111228-1245]' but it could not be found
> 
> Any ideas what this means? :)

Never seen that before, but a quick Google suggests:

http://blogs.blackmarble.co.uk/blogs/rfennell/post/2011/07/18/solution-to-missing-requirement-shared-profile-1-0-0-1308118925849-error-when-installation-tee-sp1-on-eclipse-indigo.aspx

Steve


> 
> Dima
> 
> 
> 
> On 10/11/2012 10:23 AM, Steven Bethard wrote:
>> In the Eclipse Problems view, right-click on the error and there should be a "Quick
Fix" option.
>> 
>> (The keyboard shortcut on a mac is Command+1. I use Quick Fix all the time - to import
modules, to fix syntax errors, etc.)
>> 
>> Steve
>> 
>> On Oct 11, 2012, at 8:15 AM, Dmitriy Dligach <dmitriy.dligach@childrens.harvard.edu>
wrote:
>> 
>>> Sorry, which quick fix?
>>> 
>>> Dima
>>> 
>>> On 10/11/2012 10:02 AM, Steven Bethard wrote:
>>>> On Oct 11, 2012, at 7:16 AM, Dmitriy Dligach <dmitriy.dligach@childrens.harvard.edu>
wrote:
>>>>> Still getting some errors (but different ones):
>>>>> 
>>>>> Description    Resource    Path    Location    Type
>>>>> Plugin execution not covered by lifecycle configuration:
>>>>> org.codehaus.mojo:build-helper-maven-plugin:1.7:add-source (execution:
>>>>> add-jcasgen-sources-ctakes-assertion, phase: process-resources)
>>>>> pom.xml    /ctakes-assertion    line 6 Maven Project Build Lifecycle
>>>>> Mapping Problem
>>>> Have you tried the quick fix for this?
>>>> 
>>>> (You probably need to install the build-helper m2e connector. But the quick
fix will do that for you.)
>>>> 
>>>> Steve
>>>> 
> 


Mime
View raw message