incubator-crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Friedrich (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CRUNCH-16) Fix dependency versions
Date Sat, 18 Aug 2012 07:36:38 GMT

    [ https://issues.apache.org/jira/browse/CRUNCH-16?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13437264#comment-13437264
] 

Matthias Friedrich commented on CRUNCH-16:
------------------------------------------

Cool, that's probably the best we can do for Hadoop 2, thank you.

Regarding protobuf: The patch uses 2.3.0 for hadoop-1 because hbase-0.90.4 doesn't compile
with 2.4.0a. It uses 2.4.0a for hadoop-2 because that's what Hadoop 2 has on its classpath
and that's also what hbase-0.94.1 uses. Is there something I'm overlooking? I checked via
"mvn dependency:tree" and "mvn dependency:tree -Phadoop-2".
                
> Fix dependency versions
> -----------------------
>
>                 Key: CRUNCH-16
>                 URL: https://issues.apache.org/jira/browse/CRUNCH-16
>             Project: Crunch
>          Issue Type: Task
>            Reporter: Matthias Friedrich
>            Assignee: Matthias Friedrich
>            Priority: Critical
>              Labels: maven
>         Attachments: 0001-CRUNCH-16-Fix-dependency-versions.patch
>
>
> Right now, the compile time classpath doesn't exactly match the runtime classpath. For
example, Hadoop CDH3u4 comes with slf4j-api-1.4.3 while Crunch references slf4j-api-1.6.3.
This could result in NoSuchMethodError and other nasty problems.
> We have to make sure that version numbers match (check "mvn dependency:tree") and that
we don't ship artifacts that are already present on the runtime classpath. If our dependencies
introduce incompatible transitive dependencies, we might have to downgrade them.
> Note: Maven's dependency resolution is order-dependent, see http://maven.apache.org/guides/introduction/introduction-to-dependency-mechanism.html

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message