incubator-crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriel Reid <gabriel.r...@gmail.com>
Subject Re: getting crunch running on hadoop 2.0.0
Date Wed, 27 Jun 2012 04:39:35 GMT
Something somewhat related: yesterday I had an issue when running the unit tests (or a subset
of the tests) from within Eclipse. I noticed that if the WordCountHbaseTest was run, a lot
of tests after it would fail. Not running the WordCountHbaseTest (ie setting @Ignore on it)
seemed to resolve the problem, an all tests would run through fine. 

This was only an issue when running in Eclipse; running the tests from maven seemed to work
fine. 

Any ideas on this?

On 27 Jun 2012, at 06:26, Josh Wills <jwills@apache.org> wrote:

> Hey all,
> 
> That last commit from me "fixes" (in some loose sense of the word) the
> WordCountHBaseTest, which was the last test that we needed to get
> working in order to have all of the Crunch unit tests passing under
> Hadoop-2.0.0.
> 
> The complexity stems from the fact that the WordCountHBaseTest starts
> up a mini hbase/mapreduce cluster in order to run, and I had to do
> some work to make sure that all of the proper dependencies and class
> definitions that were needed for the test case to pass were available
> to the mini YARN instance that runs w/HBaseTestingUtility under hadoop
> 2.0.0.
> 
> Vinod, if you get a chance to take a look at the test case and see if
> there is anything I could have done to make it cleaner, I would be
> much obliged.
> 
> J

Mime
View raw message