incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Newson <rnew...@apache.org>
Subject Re: Issue with CouchDB
Date Tue, 17 Jun 2014 20:04:58 GMT
Sounds like couchdb-1415

Sent from my iPhone

> On 17 Jun 2014, at 12:34, kankanala karthik <karthik.k@beehyv.com> wrote:
> 
> Hi All,
> 
> In the TAMA implementation, I came across an issue with Couchdb. (Version 1.2.0) ,  
> 
> We are using  named documents to maintain unique constraint logic in the application.
(named documents : whose _id is user defined but not couch generated.)
> 
> 
> We are using the  REST API to add the documents to Couchdb, where we found below strange
behavior : 
> 
> 
> When we try to recreate the documents using HTTP PUT which have been deleted in the past(because
of bug in the code), the documents are not created the first time .
> 
> HTTP Put - Returns HTTP 200, but doc is not saved in couchdb. 
> Again trying the same request, 
> HTTP Put - Returns HTTP 200 and adds the doc in database.
> 
> HTTP PUT request needs to be sent twice to create and save the doc.
> 
>  I have checked that the above bug is reproducible for deleted docs, i.e the response
for GET _id is {"error":"not_found","reason":"deleted"}.
> 
> This looks like a bug in CouchDB to me, could you please let us know if you could think
of any scenario where above error might occur and any possible workarounds/solutions ?
> 
> Thanks,
> Karthik.

Mime
View raw message