incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anthony Ananich <anton.anan...@inpun.com>
Subject Re: CouchDB 1.5.0 at Linux
Date Mon, 17 Feb 2014 19:16:13 GMT
That's right! I was using erlang-oauth 1.1.1. After updating to
erlang-oauth-1.4 the problem gone.

Thank you!

On Sun, Feb 16, 2014 at 9:33 PM, Robert Samuel Newson
<rnewson@apache.org> wrote:
> 'undef' means missing code, either a system library or a failure to build couchdb correctly.
>
> In this case, it sounds like a version mismatch. Couchdb includes erlang-oauth, and oauth.erl,
and recently upgraded to the 1.3.0 version which includes this;
>
> -    HeaderParams = oauth_uri:params_from_header_string(AuthHeader),
> +    HeaderParams = oauth:header_params_decode(AuthHeader),
>
> so it sounds like you’re trying to build against a system version of a library that
we include in our release.
>
> B.
>
> On 15 Feb 2014, at 19:25, Florian Westreicher Bakk.techn. <stuff@meredrica.org>
wrote:
>
>> Which headers did you send?
>>
>> Anthony Ananich <anton.ananich@inpun.com> wrote:
>>> Hi!
>>>
>>> I'm trying to make CouchDB work in RedHat EL.I was able to build it
>>> and server launches. But when I try to make any query, the server
>>> responds with HTTP Error 500:
>>>
>>> {"error":"unknown_error","reason":"undef"}
>>>
>>> In log file I can see such a messages:
>>> -----
>>> [Sat, 15 Feb 2014 14:05:29 GMT] [info] [<0.31.0>] Apache CouchDB has
>>> started on http://127.1.245.1:5984/
>>> [Sat, 15 Feb 2014 14:05:37 GMT] [error] [<0.126.0>] Uncaught error in
>>> HTTP request: {error,undef}
>>> [Sat, 15 Feb 2014 14:05:37 GMT] [info] [<0.126.0>] Stacktrace:
>>> [{oauth,header_params_decode,[[]]},
>>>                               {couch_httpd_oauth,serve_oauth,3},
>>>                               {couch_httpd,authenticate_request,2},
>>>                               {couch_httpd,handle_request_int,5},
>>>                               {mochiweb_http,headers,5},
>>>                               {proc_lib,init_p_do_apply,3}]
>>> [Sat, 15 Feb 2014 14:05:37 GMT] [info] [<0.126.0>] 127.1.245.1 - - GET
>>> /ababa 500
>>> [Sat, 15 Feb 2014 14:05:37 GMT] [error] [<0.126.0>] httpd 500 error
>>> response:
>>> {"error":"unknown_error","reason":"undef"}
>>> -----
>>>
>>> I have erlang-oauth-1.1.1 installed.
>>>
>>> I wonder if it is by design or I did something wrong? If there is a
>>> way to work around this issue?
>>>
>>> Thanks,
>>> Anthony
>>
>> --
>> Sent from Kaiten Mail. Please excuse my brevity.
>

Mime
View raw message