incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Samuel Newson <rnew...@apache.org>
Subject Re: Login link missing in 1.5 with Window IE 8
Date Tue, 18 Feb 2014 19:09:47 GMT
Patches welcome.

On 18 Feb 2014, at 18:11, Jason Winshell <jason@jasonwinshell.com> wrote:

> Thanks. 
> 
> The bug is in futon.js in the page source, line 269: "Object doesn't support this property
or method"
> 
> 
> } else if (userCtx.roles.indexOf("_admin") != -1) {  // bug is here for IE
> 	$("#userCtx .adminparty").show();
> 	$(".serverAdmin").removeAttr('disabled');
> } else {
> 	$("#userCtx .loggedout").show();
> };
> 
> IE does not support indexOf on array objects. The code need to special case for IE.
> 
> I suspect this is the page code the creates the login/sign in link. Now that I've found
the problem, what do I do? Report it where? And of course, how can I get a fix into a new
build. I'm at a bit of a loss trying to understand how a bug like this could go undetected
in an official release.
> 
> It's essential that Futon work with IE. Corporate and government installations dictate
the what software is installed on machines. A user would not be allowed to install a Couch
compatible browser.
> 
> Thanks
> 
> Jason
> 
> On Feb 18, 2014, at 12:49 AM, Garren Smith <garren@apache.org> wrote:
> 
>> Jason, could you also have a look at the IE developer console and report any errors
it shows. You might have to enable the developer console and then reload the page for any
errors to show.
>> 
>> 
>> On 18 Feb 2014, at 10:45 AM, Nick North <north.n@gmail.com> wrote:
>> 
>>> CouchDb is fully tested only against Firefox, and there are no guarantees
>>> with other browsers. That said, most things work in IE and I can see the
>>> link with IE10 on Windows 7, with that same version of CouchDb. It also
>>> works fine with Windows 8 and IE11 so I suspect it's specific to earlier IE
>>> versions, or else there is something unusual with your setup. Are you able
>>> to try it with a later version of IE? That might tell us something.
>>> 
>>> Nick
>>> 
>>> 
>>> On 17 February 2014 22:47, Jason Winshell <jasonw@bearriver.com> wrote:
>>> 
>>>> I am running CouchDB 1.5 Windows (x86) Erlang/OTP R16B01. After creating
>>>> an admin user in local.ini, the login/signup link does not appear on the
>>>> Futon Overview page when using Internet Explorer 8 (perhaps other
>>>> versions). It works fine with Firefox on Windows. Without the link, logging
>>>> in is not possible. I can create as many users as I want with Firefox. I
>>>> never see a login link on the Overview page with IE. I suspect some
>>>> Javascript compatibility weirdness. What's the story?
>>>> 
>>>> Thanks.
>> 
>> 
> 


Mime
View raw message