incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sjoerd de Jong <>
Subject Re: How to add BrowserId plugin to OSX binary install of CouchDB
Date Wed, 18 Dec 2013 22:08:55 GMT

Thanks for the extensive description. It’s a little hacky indeed but I’ve learned quite
a bit from your approach. We’re getting closer!

From a different perspective, what is the reason to not include Persona into the regular build
of CouchDB? Is it to prevent growth of the distribution?

From my point of view, Persona is great way to have decent security in a really simple setup.
It enables couchapps to be fully secure, without the need of installing any other services,
which is a major feature imho. As OAuth is already a bundled security plugin, I’d love too
see Persona / BrowserId to be bundled too!


On 18 Dec 2013, at 15:49, Dave Cottlehuber <> wrote:

> On 18. Dezember 2013 at 11:09:56, Sjoerd de Jong ( wrote:
>> Hello,
>> For some time I am struggling with getting the BrowserId (Persona)  
>> plugin running on my machine (OSX Mavericks).
>> Previously I compiled  
>> using `rake plugin="git://  
>> origin/master”` on build-couchdb. For some reason this fails  
>> for 1.5 for me, and instead of diving into the error I’d like to  
>> just use the download for OSX from the main  
>> site.
>> In Jason Smiths talk on Plugins (  
>> he showed installing a plugin is as easy as copying a .beam file  
>> into the CouchDB application. Is this also true for the downloadable  
>> version from the main website? If so, is it possible to install  
>> the BrowserId plugin this way?
>> If not, what is the recommended way to get CouchDB running with  
>> the BrowserId plugin installed?
>> Thanks for the help!
>> Sjoerd
> Hey Sjoerd,
> I’d love for Jan or Jason to chip in here, as it looks like we need
> some extra bits within the release, and I didn’t quite get this working
> either. Here’s what I tried, all very hacky:
> ```shell
> # download & unpack CouchDB 1.5.0 first
> # hack!
> cd ~/Applications/Apache\ CouchDB*.app/Contents/Resources/couchdbx-core/
> # set up path helpers
> export COUCH_PATH=`pwd -P`
> export PATH=$COUCH_PATH/lib/erlang/erts-5.10.2/bin:$COUCH_PATH/bin:$PATH
> # install erlang to update erlexec script with current location
> ./lib/erlang/Install -minimal `pwd -P`/lib/erlang
> # `erl +V` should return Erlang (SMP,ASYNC_THREADS) (BEAM) emulator version 5.10.2
> # we need erl_interface headers from a working R16B01 install as its missing
> cp -R /some/path/to/erl_interface-3.7.13 $COUCH_PATH/lib/erlang/lib/
> # get browserid_couchdb with my modified rebar.config
> cd $COUCH_PATH/lib/couchdb/erlang/lib/
> git clone git://
> cd browserid_couchdb
> ./rebar compile
> # link in the browserid.ini so couchdb finds it
> ln -s $COUCH_PATH/lib/couchdb/erlang/lib/browserid_couchdb/etc/couchdb/default.d/browserid.ini
> # have a go, I used the terminal so I can see what’s going on
> ./bin/couchdb -i
> 1> application:start(browserid_couchdb).
> # follow instructions in
> I pushed a new db and doc containing as attachment the .html snippet from
> Jason’s plugin, the logon worked fine but the account isn’t created. I’m
> missing something about how the extension should be activated too.
> A+
> dch@

View raw message