incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Carr <d.douglas.c...@gmail.com>
Subject _active_tasks replication progress stuck at 98
Date Wed, 04 Sep 2013 22:21:56 GMT
Hi all.

I'm using couchDB 1.2.1

I have a replication that I start by posting to _replicate. When I poll
_active_tasks the progress gets stuck on 98, and will not go up. This is
despite all the documents being replicated.

It appears that the source_seq is higher than it should be. As when I poll
the remotehost _changes feed, it gives a lower last_seq than the source_seq
in localhost's _active_tasks.

Any ideas what's going on here?
My code relies on the progress getting to 100, should I not do this?

Cheers,
Daniel


I've looked the entry in the log showing the start of the replication, but
can't find it. If it would be helpful, please tell me what to search for.


    curl http://localhost:5984/_active_tasks:

[{
checkpointed_source_seq: 251
continuous: true
doc_id: null
doc_write_failures: 0
docs_read: 150
docs_written: 150
missing_revisions_found: 150
pid: "<0.502.0>"
progress: 98
replication_id: "afeb3a2e577aee71c767ed96090505c6+continuous"
revisions_checked: 150
source: "http://remotehost:5984/d59423696-9e74-e111-b767-00215aac8bce-aml/"
source_seq: 255
started_on: 1378331698
target: "aml"
type: "replication"
updated_on: 1378331916
}]

    curl
http://remotehost:5984/d59423696-9e74-e111-b767-00215aac8bce-aml/_changes :

{"results":[
...
{"seq":251,"id":"fc47efd9448a47b990b01a412f7da8ce","changes":[{"rev":"1-65d41b82c27c6df7891a6bd875b18c1c"}]}
],
"last_seq":251}

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message