incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Newson <>
Subject Re: named reduce function
Date Tue, 16 Jul 2013 23:08:24 GMT
Because reduce values are calculated at view build time, not query
time, so you're basically asking the view to precompute every possible
function's output.


On 17 July 2013 00:01, Stanley Iriele <> wrote:
> just curious,
> How feasable is it for there to be named reduce functions
> and instead of reduce=true/false it could be reduce=<function name>
> and keep everything like group levels the same. and the default for no
> reduce being specified it could default to nothing false. the only
> Illegal name for a reduce function could be 'map'.
> right now I am just returning an object much like what _stats generates. I
> was just curious why or why not this was a good sounding idea

View raw message