incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From andy e <>
Subject Having trouble replicating with a large couch instance (npm repo)
Date Tue, 14 May 2013 03:30:39 GMT

Based on the awesome feedback I got from the nodejs list (see, we tried
replicating with their couch instance so we could use it in an offline

We're essentially following the instructions at but
replication fails after syncing about 17k documents.

We've tried reinstalling couch (found one issue that suggested using a
patched version of SpiderMonkey) but the same thing keeps happening, even
after restarting replication several times.

Here's our setup:

CentOS 6.4
CouchDB 1.3
SpiderMonkey 1.8.5-7

Replication works fine for over 17,000 documents, then we see this error
and can't get past it:

[Sat, 11 May 2013 00:55:39 GMT] [error] [<0.12970.4>] Replicator: couldn't
write document `bufferhelper`, revision
`19-d339684ee7f5eaf4cc18d84da753832d`, to target database `registry`.
Error: `unauthorized`, reason: `Please log in before writing to the db`.

Any ideas?



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message