incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Larsen ...@cego.dk>
Subject Replication misses documents
Date Wed, 01 May 2013 07:08:02 GMT
Hi all

I have been playing with CouchDB and I am having a weird problem.
A database I have replicated (and is continuously replicating) contains
many documents that are not present in the replicated version even thou
it says that the replication is 100% done.

And even rather old documents are missing (the database I replicate from
is itself a replication of the Node NPM registry).

Getting the 'underscore' document from the source database:
$ curl -s -X GET http://192.168.192.70:5984/registry/underscore
{"_id":"underscore","_rev":"117-eaf1f4e86f1e84f50d5df55fb56998a0","name":"underscore","description":"JavaScript's
functional programming helper
library.","dist-tags":{"latest":"1.4.4","stable":"1.4.4"},"versions":{"1.0.3":{"name":"underscore"........

Viewing the active tasks on the replicated database:
$ curl -s -X GET http://localhost:5984/_active_tasks
[{"pid":"<0.9387.5>","checkpointed_source_seq":38146,"continuous":true,"doc_id":null,"doc_write_failures":0,"docs_read":0,"docs_written":0,"missing_revisions_found":0,"progress":100,"replication_id":"34a476394d72da3f2b4d85f7f8acd50c+continuous","revisions_checked":0,"source":"http://192.168.192.70:5984/registry/","source_seq":38146,"started_on":1367329977,"target":"registry","type":"replication","updated_on":1367391827}]

See, 100% replicated.

Getting the 'underscore' document from the replication:
$ curl -s -X GET http://localhost:5984/registry/underscore
{"error":"not_found","reason":"missing"}


What have I done wrong?

Thanks
Robert


Mime
View raw message