incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Cottlehuber <...@jsonified.com>
Subject Re: An old database causes couchdb 1.3.0 to crash getting single documents
Date Mon, 29 Apr 2013 08:46:59 GMT
On 29 April 2013 09:50, Robert Newson <rnewson@apache.org> wrote:
> James,
>
> Did you compact this database with any version of couchdb between
> 0.9.0 and 1.3.0? I'm fairly sure we dropped the upgrade code for 0.9 a
> while back.
>
> B.

Yup, 1.1.2 is the last one with 0.9 on-disk format compatibility. At a
minimum you'll need to go 0.9 -> 1.1.2, compact, and then step to
1.3.0 should be OK.

Also exactly what version you're migrating from will make a difference:

    http://wiki.apache.org/couchdb/Breaking_changes

You may need to update your view code, query code as well, and it's
possible for non-valid utf-8 docs to be rejected also if they are
present. I am not sure how an upgrade handles that.

Benoit - you did a big upgrade a while back, do you remember what your
version stepping ended up requiring? IIRC you needed to go to 1.0.4
first, but I don't recall why.

A+
Dave

Mime
View raw message