incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Noah Slater <nsla...@tumbolia.org>
Subject Re: how to recreate _users database?
Date Tue, 16 Oct 2012 08:39:01 GMT
Nice turnaround!

On Mon, Oct 15, 2012 at 3:19 PM, Jan Lehnardt <jan@apache.org> wrote:

>
> On Oct 15, 2012, at 13:35 , svilen <az@svilendobrev.com> wrote:
>
> >
> >>> i was playing with replacing users-db
> >>> via /_config/couch_httpd_auth/authentication_db and an error in the
> >>> request has left some messy name in the /etc/couchdb/local.ini -
> >>> and that survives even reinstall
> >>
> >> Yeah, that is intentional, we don't want to override any
> >> customisations when you upgrade. The installer just doesn’t copy over
> >> a new local.ini when it sees an existing one. If you end up with a
> >> bad config value, that persists. Uninstalling / deleting local.ini
> >> prior to the reinstall would get you restarted cleanly.
> >
> > that's fine. Though i didnt find anywhere that touching /_config would
> > actualy rewrite local.ini.
> >
> > and it would be helpful if the wrong-name causing the trouble was
> > printed in the error-log..
>
> I agree. I committed
> http://git-wip-us.apache.org/repos/asf?p=couchdb.git;a=commit;h=66529378
>
> It should be in the upcoming 1.3.0 release.
>
> Cheers
> Jan
> --
>
> >
> > anyway, have fun
> > svilen
> >
> >>> On Mon, 15 Oct 2012 13:00:36 +0200
> >>> Jan Lehnardt <jan@apache.org> wrote:
> >>>
> >>>> That sounds odd, which CouchDB version are you running?
> >>>>
> >>>> On Oct 15, 2012, at 12:49 , svilen <az@svilendobrev.com> wrote:
> >>>>
> >>>>> hi
> >>>>> the _users db is deleted on me filesystem.
> >>>>> And now restarting couchdb fails
> >>>>> with ..illegal_database_name, ensure_users_db_exists
> >>>>>
> >>>>> reinstalling didnt help..
> >>>>> any idea?
> >>>>>
> >>>>> svilen
> >>>>
> >>
>
>


-- 
NS

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message