incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Hewitt <mar...@thenoi.se>
Subject Re: CouchDB 1.2.0, Amazon EC@ & Amazon Linux AMI
Date Mon, 03 Sep 2012 13:37:56 GMT
My SpiderMonkey libs are in /usr/local/lib/ and my header files in /usr/local/include/js as
per the ./configure command. 

I'll try playing around with LD_LIBRARY_PATH and see if that helps. 

Martin

Technical Director
Thenoi.se

w: http://www.thenoi.se
Sent with Sparrow (http://www.sparrowmailapp.com/?sig)


On Monday, 3 September 2012 at 13:54, CGS wrote:

> Where do you have SpiderMonkey installed? You need to provide the path
> toward your SpiderMonkey (libs and headers). During runtime, you can use
> all the time LD_LIBRARY_PATH to add new searching paths for libraries.
> 
> CGS
> 
> 
> 
> On Mon, Sep 3, 2012 at 2:39 AM, Martin Hewitt <martin@thenoi.se (mailto:martin@thenoi.se)>
wrote:
> 
> > Hi CGS,
> > 
> > I've just run
> > 
> > curl http://127.0.0.1:5984/_config/query_servers
> > 
> > Which gave me:
> > 
> > {"coffeescript":"/usr/local/bin/couchjs
> > /usr/local/share/couchdb/server/main-coffee.js","javascript":"/usr/local/bin/couchjs
> > /usr/local/share/couchdb/server/main.js"}
> > 
> > If I try and run:
> > 
> > /usr/local/bin/couchjs
> > 
> > I get:
> > 
> > /usr/local/bin/couchjs: error while loading shared libraries:
> > libmozjs185.so.1.0: cannot open shared object file: No such file or
> > directory
> > 
> > My ./configure command is:
> > 
> > ./configure --with-erlang=/usr/local/lib/erlang/usr/include
> > --with-js-lib=/usr/local/lib/ --with-js-include=/usr/local/include/js/
> > 
> > And libmozjs185.so.1.0 exists in /usr/local/lib/:
> > 
> > [ec2-user@ip-xx-xxx-xx-xx apache-couchdb-1.2.0]$ ls /usr/local/lib
> > couchdb erlang libmozjs185-1.0.a libmozjs185.so libmozjs185.so.1.0
> > libmozjs185.so.1.0.0 pkgconfig
> > 
> > 
> > The output of my ./configure command is here:
> > https://gist.github.com/3605914
> > 
> > Martin
> > 
> > 
> > On Saturday, 1 September 2012 at 19:37, CGS wrote:
> > 
> > > ...and I suppose you don't have SpiderMonkey there. There may be a
> > problem
> > > if js-devel is too old.
> > > 
> > > 
> > > 
> > > On Sat, Sep 1, 2012 at 7:25 PM, Martin Hewitt <martin@thenoi.se (mailto:martin@thenoi.se)
(mailto:
> > martin@thenoi.se (mailto:martin@thenoi.se))> wrote:
> > > 
> > > > Hi Dave, CGS,
> > > > 
> > > > Thanks for replying - these lines are copied directly from my CentOS
> > > > script, which works, and I haven't quite got through unpicking each
> > > > 
> > > 
> > > 
> > 
> > line
> > > > yet (if it ain't broke etc).
> > > > 
> > > > I'll try without js-devel.
> > > > 
> > > > My ./configure command is:
> > > > ./configure --with-erlang=/usr/local/lib/erlang/usr/include
> > > > --with-js-lib=/usr/local/lib/ --with-js-include=/usr/local/include/js/
> > > > 
> > > > 
> > > > Martin
> > > > 
> > > > 
> > > > On Saturday, 1 September 2012 at 18:08, Dave Cottlehuber wrote:
> > > > 
> > > > > On 1 September 2012 16:11, Martin Hewitt <martin@thenoi.se (mailto:martin@thenoi.se)
(mailto:
> > martin@thenoi.se (mailto:martin@thenoi.se)) (mailto:
> > > > martin@thenoi.se (mailto:martin@thenoi.se))> wrote:
> > > > > > Just by way of further info, this is the output of my make &&
make
> > > > > 
> > > > 
> > > > 
> > > > install command:
> > > > > > 
> > > > > > https://gist.github.com/3574166
> > > > > > 
> > > > > > I'm trying with
> > > > > > - CouchDB v1.2.0 from here:
> > > > > > 
> > > > > 
> > > > 
> > > > 
> > > 
> > 
> > http://mirror.rmg.io/apache/couchdb/releases/1.2.0/apache-couchdb-1.2.0.tar.gz
> > > > > > - SpiderMonkey 1.85 from here:
> > > > > 
> > > > 
> > > > 
> > > > http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
> > > > > > - ERLang 14B01 from here:
> > > > > 
> > > > 
> > > > 
> > > > http://www.erlang.org/download/otp_src_R14B01.tar.gz
> > > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > Martin,
> > > > > 
> > > > > What ./configure params are you using, & what's its output?
> > > > > 
> > > > > You'll only need spidermonkey 1.8.5 and not js-devel. Most likely
> > > > > that's where things are getting mucked up.
> > > > > 
> > > > > A+
> > > > > Dave
> > > > > 
> > > > 
> > > > 
> > > 
> > 
> > 
> 
> 
> 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message