incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Duffield <tom.duffi...@gmail.com>
Subject Re: _replicate error
Date Sat, 14 Jul 2012 20:46:25 GMT
Here is the sanitized command that I ran :
curl -H 'Content-Type: application/json' -X POST
http://localhost:5984/_replicate -d '{"source":
"http://<USER>:<PASS>@<EXTERNAL_DBASE>/<DBASE>",
"target": "http://localhost:5984/<DBASE>"}'


I can run _all_dbs and do POST and GET commands against both databases just
fine. I've also tried multiple external databases.

I will mention that all the external databases are running 1.1.0 while my
local database is running 1.2.0.

Thanks,
Tom


On Sat, Jul 14, 2012 at 3:21 PM, Octavian Damiean <mainerror@gmail.com>wrote:

> Can you please provide the entire curl command you've used?
>
> On Sat, Jul 14, 2012 at 9:39 PM, Tom Duffield <tom.duffield@gmail.com>
> wrote:
> > Hello,
> > Maybe someone on here can help me. I am running CouchDB 1.2.0 on RHEL 6.2
> > x86 in AWS. When I try and run the "curl localhost:5984/_replicate"
> command
> > I get (what I find to be) the most unhelpful error message:
> > {"error":"unknown_error","reason":"undef"}
> >
> > Nothing of significance shows up in the logs when I turn on the log_level
> > to DEBUG.
> >
> > Has anyone seen this before and know what is causing it? Or can someone
> > point me in a direction to look?
> >
> > Thanks,
> > Tom
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message