incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ScubbX <>
Subject Error in Spatial-Index-Creation ?
Date Sat, 21 Jul 2012 14:40:04 GMT

I get an error-return when executing a spatial view for the first time. 
Everything goes fine when using non-spatial views. The index-generation 
is aborting and the following error is displayed:


This happens with different CouchDB installations (Ubuntu 12.04, a 
self-compiled 1.2.0 and an older CouchBase in a VirtualMachine) on large 
databases (in this case 440.000 entries, the error happens after about 
processing 18.000). The view worked fine when executed on a database 
with only about 2.300 entries.

The spatial view looks like this (it has become a bit bloated because of 

function(doc) {
     if(doc.geometry && {
         if( && doc.geometry.coordinates){
             if( {
                 if( == "bicycle_parking") {
                     emit(doc.geometry, 1);

I tried other spatial-views but they produce the same error. It seems to 
me like an internal problem, or could there be something wrong with the 
data? The document that produced the error is this:


I hope you can see something wrong her and would appreciate your help or 


PS: The installations of the master-branch of CouchDB is going fine, but 
the master of GeoCouch does not compile for me.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message