incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Volker Mische <volker.mis...@gmail.com>
Subject Re: geocouch with polygons
Date Wed, 11 Jul 2012 15:19:22 GMT
Hi Paul

On 07/11/2012 03:44 AM, Paul Torres wrote:
> Does anyone have any experience with the latest experimental geocouch
> that supports
> polygons? From: https://github.com/vmx/geocouch/tree/couchdbgeom

Yes ;)

> Being experimental, does that mean the tests in the futon test suite do not
> neccessarily all pass? I have a few that are failing, but I cannot track down
> any (more) of my own errors that might be causing it. I have all the
> dependencies
> including GEOS available in my PATH, and my ERL_FLAGS are set, etc. I
> compiled and copied the .ini file and the tests and updated the list
> of tests that
> should be run... I'm running couch 1.1.0 compiled from source.

All Futon tests should work. The problem might be that this version is
for CouchDB 1.2.0 and was only tested with it.

> Poking around the makefile for the geocouch I noticed it included targets for
> running tests and these do not all pass either, so it would seem to me that
> something might be wrong at the compilation stage. If true then I guess the
> code just needs more work. But is that the case? I'm not very fluent in Erlang
> yet to read it all and determine definitely for myself and I'd like to
> double check
> with anyone who knows for certain.

Try again with CouchDB 1.2.0 and let me know if it still doesn't pass
all tests.

Cheers,
  Volker


Mime
View raw message