incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Cottlehuber <d...@muse.net.nz>
Subject Re: Upgrade from 1.1.0 to 1.2.0
Date Wed, 20 Jun 2012 21:49:44 GMT
On 20 June 2012 23:31, Ronnie F. Moller, Jr.
<ronnie@redbaronconsulting.com> wrote:
>> -----Original Message-----
>> From: Dave Cottlehuber [mailto:dave@muse.net.nz]
>> Sent: Wednesday, June 20, 2012 4:12 PM
>> To: user@couchdb.apache.org
>> Subject: Re: Upgrade from 1.1.0 to 1.2.0
>>
>> On 20 June 2012 22:33, Ronnie F. Moller, Jr.
>> <ronnie@redbaronconsulting.com> wrote:
>> >
>> >>
>> >> I am moving servers and in the process upgrading to 1.2.0.
>>
>> I.e. on new server you have 1.2.0 installed, and the old one has 1.0.1
> ?
>
> Yes. Not touching the original old server.
>>
>> >> My plan is to move the couchdb files manually. The old server
> definition
>> has a util driver of couch-1.0.1, so I updated this to 1.2.0.
>>
>> Um you mean your edited default.ini? Or this was found in your
> local.ini file?
>> You shouldn't need to add this to the new server's local.ini
>
> The old server had this in the default.ini, and the default.ini is what
> was modified to point to the new data directory, instead of overriding
> the local.ini. I guess I could leave the default.ini stock, and do just
> modify the local.ini where needed. This does produce the same
> end-results, as long as I do not include the util-driver line.
>
>> >> Now when I run the web interface I get a growing log file and the
> erlang
>> debug window shows lots of numbers just streaming.
>> >>
>> >> Is this an upgrade process, or did I make a bad assumption on the
>> process?
>>
>> does curling / work?
>>
>> how are you starting couchdb? any immediate errors on startup
>>
>
> I am starting couchdb using the "start couch" batch file so that the
> debug window for erl is shown. I can browse to the utils, and everything
> appears normal until I attempt to login as a user. Then it outputs a
> constant scrolling of numbers separated by spaces. At first I thought
> this was an update, until I realized they were not incrementing, but
> appear random.

Hi Ronnie,

You're making it *really* hard for us to help here. Mentioning that it's
running Windows is significant (even I assumed otherwise).

What OS are you running & which build of CouchDB?

Did you verify the installation before moving your DB files in?

-> fresh install of couchdb to an empty directory
-> launch any browser except IE
-> open futon
-> right-hand side is a "verify install" button

Does that work?

If not, restart couchdb & don't run futon, just provide output using

    curl -v http://localhost:5984/

And please copy & paste the output from the werl window somewhere
(not in email) please, e.g. friendpaste?

Unfortunately I'm off for the evening here, I'll look tomorrow for your
update.

A+
Dave

Mime
View raw message