incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Elisiano Petrini <elisi...@gmail.com>
Subject Re: Couchdb: make check failure
Date Mon, 02 Apr 2012 09:07:53 GMT
Hi Paul,
     the operating system is SLC 5 [ http://www.ScientificLinux.org ].
It's built on Red Hat sources à la CentOS (but with some customizations).
In this context you can consider it a Red Hat 5.

I didn't use the default versions of erlang and spidermonkey, instead I 
used more recent versions that some folks here at work compiled (because 
they packaged also the version 1.1.1 of couchdb):
# rpm -qa|egrep "^(erlang-R|js-)"
js-1.8.5-6
js-devel-1.8.5-6
erlang-R14B-03.3.el5

I tried to have a look at the failing test code 
(test/etap/200-view-group-no-db-leaks.t) but I would have no idea how to 
modify it in order to find out which test is failing (and I didn't find 
any specific logs about it).

As reported in the original post, the user used is root, which I'm aware 
being a bad idea but this was just to test that everything worked before 
a real deploy.

Cheers, Elisiano.

On 04/01/2012 08:00 PM, Paul Davis wrote:
> Awkward. This is a specific test that you can mostly ignore as we're
> only using it to test the behavior of errors when views are opened.
> Though I would be quite interested to know how that test fails for
> you. Basically what happens is that we create a view, close it, remove
> read permissions and then try and open it. I wonder if its perhaps not
> closing quickly enough and you're getting a cached copy maybe?
>
> Also, what OS and what user are you running the tests as?
>
> On Fri, Mar 30, 2012 at 6:49 AM, Elisiano Petrini<elisiano@gmail.com>  wrote:
>> I forgot to include the detailed test log in the previous post.
>>
>> It can be found here: http://paste.pocoo.org/show/573495/
>>
>>
>> Cheers, Elisiano


Mime
View raw message