incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Davis <paul.joseph.da...@gmail.com>
Subject Re: Bad utf8 character code error
Date Mon, 19 Mar 2012 08:21:15 GMT
Are you replicating between different versions of CouchDB? My first
guess is that you've replicating older to newer and its hitting a
stricter enforcement of Unicode semantics in surrogate pairs.

On Mon, Mar 19, 2012 at 3:04 AM, Karoly Szanto <szanto.karoly@gmail.com> wrote:
> Hi,
> During the replication proces I get the following error in the couchdb
> server log:
>
>                       {<0.13261.0>,crash_report,
>                        [[{initial_call,
>                           {mochiweb_acceptor,init,
>                            ['Argument__1','Argument__2','Argument__3']}},
>                          {pid,<0.13261.0>},
>                          {registered_name,[]},
>                          {error_info,
>                           {exit,
>                            {ucs,{bad_utf8_character_code}},
>                            [{xmerl_ucs,from_utf8,1},
>                             {mochijson2,json_encode_string,2},
>
>  {mochijson2,'-json_encode_proplist/2-fun-0-',3},
>                             {lists,foldl,3},
>                             {mochijson2,json_encode_proplist,2},
>                             {couch_httpd,send_json,4},
>                             {couch_httpd,handle_request_int,5},
>                             {mochiweb_http,headers,5}]}},
>                          {ancestors,
>                           [https,couch_secondary_services,couch_server_sup,
>                            <0.35.0>]},
>                          {messages,
>                           [{#Ref<0.0.8.97038>,
>                             {ok,
>                              {proc,<0.7774.0>,<<"javascript">>,
>                               [{<<"_design/monarcaserver">>,
>
>  <<"469-a002d8a3c537c48875b315164d8eadb6">>}],
>                               {couch_os_process,prompt},
>                               {couch_os_process,set_timeout},
>                               {couch_os_process,stop}},
>                              {[{<<"reduce_limit">>,true},
>                                {<<"timeout">>,30000}]}}}]},
>                          {links,[<0.136.0>]},
>                          {dictionary,
>                           [{mochiweb_request_body,<<>>},
>                            {mochiweb_request_qs,
>                             [{"filter","monarcaserver/userfilter"},
>                              {"userid","70"},
>                              {"feed","continuous"},
>                              {"heartbeat","10000"},
>                              {"style","all_docs"},
>                              {"since","0"}]},
>                            {jsonp,no_jsonp},
>                            {mochiweb_request_cookie,[]}]},
>                          {trap_exit,false},
>                          {status,running},
>                          {heap_size,4108475},
>                          {stack_size,24},
>                          {reductions,5319640}],
>                         []]}}
>
> My first guess is that this might be solved by specifying the charset in
> the replication header but I'd like to know your opinion as well.
>
> Thank you,
> Karoly
Mime
View raw message