incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pete Vander Giessen <pet...@gmail.com>
Subject Re: User authentication failures
Date Tue, 06 Dec 2011 22:49:33 GMT
Hi All,

> I created an issue to track your problem:
>
> https://issues.apache.org/jira/browse/COUCHDB-1357
>
> Is there a deterministic way to reproduce your issue?
> A sequence of exact steps, or a script, would be the ideal.

We ran into a similar issue, with 1.1.1. The problem seemed to start
with a log entry that looked like so:

[Thu, 01 Dec 2011 19:22:48 GMT] [error] [<0.31233.1889>] Uncaught
error in HTTP request: {error,system_limit}
[Thu, 01 Dec 2011 19:22:48 GMT] [info] [<0.31233.1889>] Stacktrace:
[{erlang,open_port,
                                      [{spawn,"couch_icu_driver"},[]]},
                                     {couch_util,drv_port,0},
                                     {couch_util,collate,3},
                                     {couch_view,less_json_ids,2},
                                     {couch_btree,drop_nodes,4},
                                     {couch_btree,stream_kp_node,8},
                                     {couch_btree,fold,4},
                                     {couch_view,fold,4}]

We had a cluster of 7 or so Windows users replicating 2 databases
apiece from a "master" server running on Red Hat. Each user also has a
separate "user" database that they use to fetch oauth credentials, so
there were perhaps 16 databases in use at the time.

Next time this happens, I'll run netstat on the machine and save the
output. For now, I've saved off the logs, and can provide more
complete logs upon request.

I'll cross-post this as a comment to the bug (and I'm logged into the
#couchdb channel as "petevg" if anybody has realtime questions for
me).

~ PeteVG

Mime
View raw message