incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pulkit Singhal <pulkitsing...@gmail.com>
Subject Re: can't control config chain
Date Sat, 17 Dec 2011 01:26:51 GMT
Simple things that i ran into with function_clause (just a de-facto
stacktrace word to me it seems) were:
(a) another couchdb still running, or (b) not starting couchdb with the
user who is part of the admin/sudo group.

On Fri, Dec 16, 2011 at 5:19 PM, Mark Hahn <mark@hahnca.com> wrote:

> aarrgghh - I need help
>
> I removed all options from default.ini that were in local.ini and then
> copied these two files to both the build directory that shows in couchdb
> -c, and to my desired location.
>
> Now the config page in futon looks good but when futon tries to retrieve
> the db list I get an error saying it couldn't retrieve the dbs.  The
> message ends with a cryptic  "function_clause".
>
> BTW, I'm sure the build is good.  I have been running couchdb successfully
> for some time in this installation.  It wasn't until I tried re-configuring
> that all hell broke loose.
>
> On Fri, Dec 16, 2011 at 3:05 PM, Mark Hahn <mark@hahnca.com> wrote:
>
> > I've just discovered that the duplicates are happening on all values that
> > are both in default.ini and in local.ini.  So the override is not
> working.
> >  I'll temporarily modify default.ini to get past this, but this should be
> > fixed.
> >
> >
> > On Fri, Dec 16, 2011 at 3:00 PM, Mark Hahn <mark@hahnca.com> wrote:
> >
> >> Another weird thing is happening.  I've got a bunch of duplicate entries
> >> being shown in futon config page.  One entry will be from the .ini file
> in
> >> my location (/ria/etc/db) and the other from the default location (
> >> /root/build-couchdb/build/etc/couchdb ).
> >>
> >> How can this happen?  I'm using the -n option in my command to clear the
> >> chain.  Also, how could the futon page show any duplicates?  Wouldn't
> any
> >> later .ini setting replace an earlier one?
> >>
> >> An example of a futon duplicate follows.  These are adjacent lines in
> the
> >> [couchdb] section.
> >>
> >>  *uri_file* /root/build-couchdb/build/var/run/couchdb/couch.uri
> >> x <http://dev.comps2.info:5984/_utils/config.html#remove>
> >> *uri_file* /mnt/db/couch.uri
> >> x <http://dev.comps2.info:5984/_utils/config.html#remove>
> >>
> >>
> >> On Fri, Dec 16, 2011 at 2:37 PM, Mark Hahn <mark@hahnca.com> wrote:
> >>
> >>> Here is the command line I use to start couch.
> >>>
> >>> /root/build-couchdb/build/bin/couchdb -n \
> >>> -a /ria/etc/db/default.ini \
> >>>  -a /ria/etc/db/local.ini \
> >>> -p /mnt/db/couch.pid \
> >>>  -o /mnt/db/couch.stdout \
> >>> -e /mnt/db/couch.stderr \
> >>>  -R -b -r 0 &
> >>>
> >>>   A `ps aux` command shows this is the only version of couch running.
> >>>  This is the resulting config chain ...
> >>>
> >>> $ couchdb -c
> >>> /root/build-couchdb/build/etc/couchdb/default.ini
> >>> /root/build-couchdb/build/etc/couchdb/local.ini
> >>>
> >>> The running version of couch is using this wrong config.  What am I
> >>> doing wrong?
> >>>
> >>> I am using couch 1.1.1 on Ubuntu 10.04.3.
> >>>
> >>>
> >>>
> >>
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message